aspose.info
FA

ICS - فرمت فایل iCalendar

به‌روزرسانی

فایل ICS چیست؟

تقویم اینترنتی و زمان‌بندی مشخصات شی اصلی (iCalendar) یک استاندارد اینترنتی (RFC 2445) برای تبادل و استقرار رویدادهای تقویم و زمان‌بندی است. فرمت iCalendar قابل اجرا است و در نتیجه تبادل اطلاعات تقویم را بین کاربرانی که برنامه های ایمیل مختلف دارند تضمین می کند. iCalendar داده های ورودی را به عنوان یک برنامه افزودنی ایمیل چند منظوره اینترنتی (MIME) قالب بندی می کند و شی رد و بدل شده از طریق پروتکل های انتقال مختلف را تسهیل می کند. این پروتکل های انتقال می توانند SMTP، HTTP، ارتباطات ناهمزمان نقطه به نقطه و انتقال شبکه مبتنی بر رسانه فیزیکی باشند.

iCalendar به کاربران اجازه می‌دهد رویدادها، وظایف وابسته به تاریخ/زمان و اطلاعات آزاد/مشغول را از طریق ایمیل با سایر کاربرانی که می‌توانند پاسخ دهند به اشتراک بگذارند. فایل‌های iCalendar با استفاده از پسوندهای .ics .iCalendar یا .ifb با نوع MIME text/calendar ذخیره می‌شوند. iCalendar بدون هیچ گونه وابستگی به پروتکل حمل و نقل، متکی به خود است. سرورهای وب (با پروتکل HTTP) می توانند اطلاعات iCalendar را انتقال دهند و صفحات وب می توانند داده های iCalendar را به شکل جاسازی شده با استفاده از iCalendar در خود داشته باشند.

تاریخچه مختصر فرمت فایل ICS

In 1998, the Internet Engineering Task Force (IETF) defined iCalendar as a standard (RFC 2445). The standard was documented by Frank Dawson(Lotus Notes Corporation) and Derik Stenerson ( Microsoft). In 2009, the standard was again refined by Bernard Desruisseaux (Oracle) as RFC 5545. این بار برخی از ویژگی های جدید اضافه شد و برخی از ویژگی های قدیمی منسوخ شدند. در سال 2016، RFC 7986 منتشر شد و به iCalendar RFC اصلی افزوده شد. RFC 7986 ویژگی های جدیدی را به شی اصلی VCALENDAR اضافه کرد و ویژگی های جدید پشتیبانی نیز برای سیستم های کنفرانس معرفی شد.

فرمت فایل ICS

نوع MIME استفاده شده توسط داده های iCalendar متن/تقویم است. مجموعه کاراکترهای پیش‌فرض برای iCalendar UTF-8 است، اما با ارائه پارامترها در MIME، می‌توان از مجموعه کاراکترهای متفاوتی استفاده کرد. یک فایل iCalendar شامل بخش‌هایی است که در میان این بخش‌ها VCALENDAR بخش سراسری است که تمام بخش‌های دیگر را در بر می‌گیرد. بخش VEVENT رویدادها را تعریف می کند، VTODO همه موارد کار را فهرست می کند، VJOURNAL شامل ورودی های مجله است و VTIMEZONE اطلاعات منطقه زمانی را مشخص می کند. چندین بخش از دسته مشابه مجاز است. برای رویدادهای متعدد، چندین بخش VEVENT می‌تواند در یک فایل iCalendar وجود داشته باشد.

خطوط محتوا

اشیاء iCalendar در خطوط متمایز متن خطوط محتوا مرتب شده اند. در این فرمت فایل، دنباله CRLF یک خط را خاتمه می دهد در حالی که طول خط به استثنای شکست خط به 75 اکتت محدود می شود. یک آیتم داده طولانی را می توان به بسیاری از خطوط باز کرد.

جداکننده لیست و فیلد

ویژگی ها و پارامترها لیستی از مقادیر را مشخص می کنند که با یک کاراکتر COMMA از هم جدا شده اند. quoted-strings برای مقادیر پارامتر مبتنی بر URI استفاده می شود. لیست پارامترها را می توان با مقدار ویژگی ساخت. هر پارامتر ویژگی در این لیست باید با SEMICOLON از هم جدا شود.

در یک لیست مقادیر، یک SEMICOLON پارامترهای ویژگی و یک COMMA مقادیر ویژگی را جدا می کند. مثال در زیر آورده شده است:

ATTENDEE;RSVP#TRUE;ROLE#REQ- contestant:mailto:
name@example.com
DATE;VALUE#DATE:20170304,20180504,2015704,201270904

مقادیر چندگانه

برخی از ویژگی ها می توانند چندین مقدار داشته باشند. ایجاد یک خط محتوای جدید با نام ویژگی، قانون اساسی برای خواص چند ارزشی است. با این حال، برای یک مقدار واحد با تغییرات چند زبانه نباید از ویژگی های چند ارزشی استفاده شود.

محتوای باینری

در یک شی iCalendar، مقدار ویژگی می تواند به یک داده محتوای باینری که در یک موجودیت MIME خارجی با استفاده از یک URI قرار داده شده است ارجاع دهد. محتوای باینری درون خطی را می توان در شرایط خاص با پارامتر ENCODING استفاده کرد، جایی که برنامه باید یک شی iCalendar را به عنوان یک موجودیت بیان کند. مثال زیر یک ویژگی ATTACH را با یک مرجع URI توضیح می دهد:

ATTACH: https://products.conholdate.app/viewer/view/KDDURXKkLk/fileformat.doc

مجموعه کاراکتر

اگرچه طرح پیش‌فرض مجموعه حروف برای iCalendar UTF-8 است، اما هیچ پارامتر خاصیت برای تعریف مجموعه نویسه‌های یک مقدار مشخص نشده است. در انتقالات MIME پارامتر charset باید برای مجموعه نویسه های موجود استفاده شود.

چگونه یک فایل ICS را باز کنیم؟

راه های مختلفی برای باز کردن یک فایل ICS وجود دارد. اینها به تفصیل در زیر آمده است.

  1. ICS را با استفاده از برنامه های تقویم باز کنید

می‌توانید فایل‌های ICS را با استفاده از برنامه‌های تقویم مانند Microsoft Outlook، Google Calendar یا Apple Calendar باز کنید. اگر این برنامه ها را روی دستگاه خود نصب کرده اید، می توانید فایل ICS را با این برنامه ها به سادگی با دوبار کلیک کردن روی آن باز کنید. با این کار رویدادهای فایل ICS به تقویم شما وارد می شود.

  1. فایل ICS را در ویرایشگر متن باز کنید

همچنین می توانید یک فایل ICS را در هر ویرایشگر متنی مانند Microsoft Notepad یا Apple TextEdit باز کنید. پس از باز شدن، خطوط DTSTART و DTEND را خواهید دید که زمان شروع و پایان رویداد را نشان می دهند.

  1. وارد کردن دستی فایل ICS در برنامه تقویم

همچنین می‌توانید با استفاده از گزینه‌های Imiprot و صادرات این برنامه‌های تقویم، یک فایل ICS را به صورت دستی به برنامه تقویم خود وارد کنید. با این کار رویدادهای فایل ICS به تقویم شما اضافه می شود.

منابع