<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom"><channel><title>電子メール ファイルの形式と,電子メール ファイルを開いて作成できる API について学習する on aspose.info</title><link>https://www.aspose.info/ja/email/</link><description>Recent content in 電子メール ファイルの形式と,電子メール ファイルを開いて作成できる API について学習する on aspose.info</description><generator>Hugo</generator><language>ja</language><lastBuildDate>Mon, 31 Jan 2022 00:00:00 +0000</lastBuildDate><atom:link href="https://www.aspose.info/ja/email/index.xml" rel="self" type="application/rss+xml"/><item><title>P7S ファイル - デジタル署名された電子メール メッセージ</title><link>https://www.aspose.info/ja/email/p7s/</link><pubDate>Mon, 31 Jan 2022 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/p7s/</guid><description>&lt;h2 id="p7s-ファイルとは何ですか"&gt;.P7S ファイルとは何ですか?&lt;a class="anchor" href="#p7s-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e3%81%a8%e3%81%af%e4%bd%95%e3%81%a7%e3%81%99%e3%81%8b" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;P7S ファイルは、デジタル署名された電子メールで受信されるデジタル署名です。このファイルが電子メールの添付ファイルとして存在することで、電子メールが本物の送信元から送信されたことを確認できます。これにより、送信者のコンピューターに電子メール署名証明書がインストールされていることが保証されます。このような署名付き電子メールがユーザーのコンピューターから送信されると、送信者の名前を含む P7S ファイルが添付されます。署名付き電子メールをサポートする電子メール クライアントは、送信者の情報を見ることができます。&lt;/p&gt;&#10;&lt;h2 id="p7s-ファイル形式---詳細情報"&gt;P7S ファイル形式 - 詳細情報&lt;a class="anchor" href="#p7s-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f---%e8%a9%b3%e7%b4%b0%e6%83%85%e5%a0%b1" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;S/MIME (Secure/Multipurpose Internet Mail Extensions) P7S ファイルには、人間が判読できるプレーン テキスト形式の情報が含まれています。 Microsoft Outlook、Apple Mail、Mozilla Thunderbird などの電子メール クライアントは、S/MIME 電子メールからデジタル署名された情報を読み取ることをサポートしています。電子メールに署名すると、送信者の身元が確認され、メッセージが本物であることを受信者に伝えます。電子メールが電子メール クライアント (&lt;a href="https://www.aspose.info/ja/email/eml/"&gt;EML&lt;/a&gt; または &lt;a href="https://www.aspose.info/ja/email/msg/"&gt;MSG&lt;/a&gt;) からダウンロードされると、これらの P7S ファイルがこれらの電子メールに添付されていることがわかります。&lt;/p&gt;&#10;&lt;p&gt;P7S ファイルには、次の情報が含まれています。&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;メールの発信元&lt;/li&gt;&#10;&lt;li&gt;送信日時、&#10;*送信中に変更されたかどうか&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;この情報は、Public-Key Cryptography Standard #7 (PKCS7) テクノロジを使用して埋め込まれ、暗号化された署名が電子メールにデジタル的に添付されます。&lt;/p&gt;&#10;&lt;h2 id="参照"&gt;参照&lt;a class="anchor" href="#%e5%8f%82%e7%85%a7" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;&lt;a href="https://learn.microsoft.com/en-us/windows-hardware/drivers/devtest/signtool"&gt;Microsoft 署名ツール&lt;/a&gt;&lt;/li&gt;&#10;&lt;/ul&gt;</description></item><item><title>EDBファイル形式 - Exchangeメールデータベースファイル</title><link>https://www.aspose.info/ja/email/edb/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/edb/</guid><description>&lt;h2 id="edb-オプション番号"&gt;.EDB オプション番号&lt;a class="anchor" href="#edb-%e3%82%aa%e3%83%97%e3%82%b7%e3%83%a7%e3%83%b3%e7%95%aa%e5%8f%b7" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;.edb ファイル拡張子を持つファイルは、メール関連のデータを格納するために Microsoft Exchange Server によって作成されるメールボックス データベースです。 EDB、Exchange データベースは、インプロセスで非 SMTP のメッセージを保存します。 EDB は Extensible Storage Engine (ESE) データベース ファイルとも呼ばれ、b ツリー構造を使用してファイルを保存します。ストレージ ファイルである EDB ファイルは、&lt;a href="https://www.aspose.info/ja/email/pst/"&gt;PST&lt;/a&gt; や &lt;a href="https://www.aspose.info/ja/email/ost/"&gt;OST&lt;/a&gt; などの他のメール ストレージ ファイル形式に変換できます。&lt;/p&gt;&#10;&lt;h2 id="edb-ファイル形式"&gt;EDB ファイル形式&lt;a class="anchor" href="#edb-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;参照できる公式/オープンな EDB ファイル形式の仕様はありません。ファイル形式のリバース エンジニアリングがある程度進んでおり、部分的な仕様のデコードが行われています。これらに従って、EDBファイルは次のもので構成されます。&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;ファイル ヘッダー - データベース ファイルのヘッダー情報が含まれます&lt;/li&gt;&#10;&lt;li&gt;固定サイズのページ - テーブルとインデックスで構成されるデータベースが含まれています&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;h3 id="データベース-ファイル-ヘッダー"&gt;データベース ファイル ヘッダー&lt;a class="anchor" href="#%e3%83%87%e3%83%bc%e3%82%bf%e3%83%99%e3%83%bc%e3%82%b9-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab-%e3%83%98%e3%83%83%e3%83%80%e3%83%bc" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;データベース ファイル ヘッダーは最初のデータベース ページにあり、少なくとも 668 バイトです。ファイル ヘッダーには、他のフィールドに加えて、「ファイル フォーマット バージョン」と「ファイル タイプ」が含まれます。&lt;/p&gt;&#10;&lt;p&gt;＃＃＃＃ ファイルタイプ&lt;/p&gt;&#10;&lt;table&gt;&#10;&#9;&lt;thead&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;タイプ&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;説明&lt;/th&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/thead&gt;&#10;&#9;&lt;tbody&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;データベース&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;ストリーミング&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/tbody&gt;&#10;&lt;/table&gt;&#10;&lt;p&gt;&lt;code&gt;注:&lt;/code&gt; これらのタイプの識別子は不明です。&lt;/p&gt;&#10;&lt;h4 id="ファイル形式のバージョン"&gt;ファイル形式のバージョン&lt;a class="anchor" href="#%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f%e3%81%ae%e3%83%90%e3%83%bc%e3%82%b8%e3%83%a7%e3%83%b3" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h4&gt;&#10;&lt;p&gt;EDB の元の形式は 1997 年 4 月に開始され、その後も変更のために進化を続けました。&lt;/p&gt;</description></item><item><title>EML - メールメッセージ</title><link>https://www.aspose.info/ja/email/eml/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/eml/</guid><description>&lt;h2 id="eml-オプション番号"&gt;.EML オプション番号&lt;a class="anchor" href="#eml-%e3%82%aa%e3%83%97%e3%82%b7%e3%83%a7%e3%83%b3%e7%95%aa%e5%8f%b7" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;EML ファイル形式は、Outlook およびその他の関連アプリケーションを使用して保存された電子メール メッセージを表します。ほとんどすべての電子メール クライアントは、RFC-822 Internet Message Format Standard に準拠するために、このファイル形式をサポートしています。 Microsoft Outlook は、EML メッセージ タイプを開くためのデフォルトのソフトウェアです。 EML ファイルは、ディスクへの保存や、通信プロトコルを使用した受信者への送信に使用できます。&lt;/p&gt;&#10;&lt;h2 id="emlの歴史"&gt;EMLの歴史&lt;a class="anchor" href="#eml%e3%81%ae%e6%ad%b4%e5%8f%b2" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;EML ファイル形式の仕様は、&lt;a href="https://www.ietf.org/rfc/rfc0822.txt"&gt;RFC 822&lt;/a&gt; 標準形式に従って入手できます。 RFC-822 より前は、RFC-733 がネットワーク メッセージ交換のルールを管理していましたが、1982 年に前者は ARPA 標準を確立することによりラテラルの改良として作成されました。同時に、Microsoft は独自の電子メール クライアント、つまり Outlook Express を開発するための独自の COM モジュールを作成しました。 RFC-822 は、Microsoft がオープン スタンダードから逸脱し、電子メールが高度に構造化されたデータベース形式で保存される &lt;a href="https://www.aspose.info/ja/email/pst/"&gt;PST&lt;/a&gt; ファイル形式を作成したときに、独自の形式として確立される道をたどりました。これにより、電子メールが Microsoft Outlook から転送されたときに、Microsoft 以外の電子メール クライアントのユーザーに問題が発生しました。&lt;/p&gt;&#10;&lt;p&gt;822 標準が 2822 (MIME RFC-822 形式で EML メッセージを作成、読み取り、送信するために現在使用されている Internet Message Format) に拡張されたのは 2001 年でした。&lt;/p&gt;&#10;&lt;h2 id="eml-ファイル形式の仕様"&gt;EML ファイル形式の仕様&lt;a class="anchor" href="#eml-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f%e3%81%ae%e4%bb%95%e6%a7%98" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;EML ファイルは、次の 2 つのセクションで構成されています。&lt;/p&gt;</description></item><item><title>EMLX - Apple Mail ファイル形式</title><link>https://www.aspose.info/ja/email/emlx/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/emlx/</guid><description>&lt;h2 id="emlx-オプション番号"&gt;.EMLX オプション番号&lt;a class="anchor" href="#emlx-%e3%82%aa%e3%83%97%e3%82%b7%e3%83%a7%e3%83%b3%e7%95%aa%e5%8f%b7" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;EMLX ファイル形式は、Apple によって実装および開発されています。 Apple Mail アプリケーションは、電子メールのエクスポートに EMLX ファイル形式を使用します。 EMLXファイルを開いて、これらを他のファイル形式に変換できる他のアプリケーションもあります。&lt;/p&gt;&#10;&lt;h2 id="emlx-ファイル形式の歴史"&gt;EMLX ファイル形式の歴史&lt;a class="anchor" href="#emlx-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f%e3%81%ae%e6%ad%b4%e5%8f%b2" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;Mac OS X オペレーティング システムは、NeXTSTEP オペレーティング システムの一部として NeXT によって作成された既存の電子メール プログラム、NeXTMail を採用しました。 Apple は NeXT を買収した後、その機能を強化し、デフォルトのメール クライアントとして使用される Apple Mail メール アプリケーションになりました。 Apple Mail 経由でエクスポートされた電子メールは、EMLX ファイルとして直接保存されます。さらに、誰かが Mac OS でこれらをダブルクリックして開くと、EMLX ファイルのデフォルトのメール クライアントになります。&lt;/p&gt;&#10;&lt;h2 id="emlx-ファイル形式"&gt;EMLX ファイル形式&lt;a class="anchor" href="#emlx-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;EMLx ファイルは、メモ帳などのテキスト エディターで開くことができる単純なテキスト ベースのファイルです。 EMLX ファイル構造は、次の 3 つの部分で構成されています。&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;メッセージのバイト数 - ASCII で 10 進数で記述され、0x0a で終了するメッセージ自体の長さ&#10;※メッセージそのもの&lt;/li&gt;&#10;&lt;li&gt;XML plist 形式のメッセージ メタデータ&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;これらは、Apple Mail から EMLX として抽出された次のサンプル メールをテキスト エディターで開くことで、よりよく説明できます。&lt;/p&gt;</description></item><item><title>ICS - iCalendar ファイル形式</title><link>https://www.aspose.info/ja/email/ics/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/ics/</guid><description>&lt;h2 id="ics-ファイル拡張子"&gt;.ICS ファイル拡張子&lt;a class="anchor" href="#ics-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e6%8b%a1%e5%bc%b5%e5%ad%90" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;Internet Calendaring and Scheduling Core Object Specification (iCalendar) は、カレンダー イベントとスケジューリングを交換および展開するためのインターネット標準 (RFC 2445) です。 iCalendar 形式は相互運用可能であるため、さまざまな電子メール アプリケーションを使用しているユーザー間でカレンダー情報を交換できます。 iCalendar は、入力データを Multipurpose Internet Mail Extensions (MIME) としてフォーマットし、さまざまなトランスポート プロトコルを介して交換されるオブジェクトを容易にします。これらのトランスポート プロトコルには、SMTP、HTTP、ポイント ツー ポイント非同期通信、および物理メディア ベースのネットワーク トランスポートがあります。&lt;/p&gt;&#10;&lt;p&gt;iCalendar を使用すると、ユーザーはイベント、日付/時間依存のタスク、空き時間情報を電子メールで他のユーザーに共有できます。他のユーザーは返信できます。 iCalendar ファイルは、サフィックス「.ics」「.iCalendar」または「.ifb」を使用して保存され、MIME タイプは「text/calendar」です。 iCalendar は、トランスポート プロトコルに依存することなく、自立した状態に保たれています。 Web サーバー (HTTP プロトコルを使用) は iCalendar 情報を転送でき、Web ページには iCalendar を使用して埋め込み形式で iCalendar データを含めることができます。&lt;/p&gt;&#10;&lt;h2 id="ics-ファイル形式の歴史"&gt;ICS ファイル形式の歴史&lt;a class="anchor" href="#ics-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f%e3%81%ae%e6%ad%b4%e5%8f%b2" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;1998 年、Internet Engineering Task Force (IETF) は iCalendar を標準 (RFC 2445) として定義しました。この標準は、Frank Dawson (Lotus Notes Corporation) と Derik Stenerson (Microsoft) によって文書化されました。 2009 年に、標準は Bernard Desruisseaux (Oracle) によって RFC 5545 として再び洗練されました。今回は、いくつかの新しい機能が追加され、いくつかの古い機能が廃止されました。 2016 年に RFC 7986 がリリースされ、元の iCalendar RFC に拡張されました。 RFC 7986 はメインの VCALENDAR オブジェクトに新しい特性を追加し、新しいサポート機能も会議システムに導入されました。&lt;/p&gt;</description></item><item><title>MBOX - メールボックスファイル</title><link>https://www.aspose.info/ja/email/mbox/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/mbox/</guid><description>&lt;h2 id="mbox-ファイルとは何ですか"&gt;.MBOX ファイルとは何ですか?&lt;a class="anchor" href="#mbox-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e3%81%a8%e3%81%af%e4%bd%95%e3%81%a7%e3%81%99%e3%81%8b" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;MBox ファイル形式は、電子メール メッセージのコレクションのコンテナーを表す一般的な用語です。メッセージは、添付ファイルとともにコンテナ内に保存されます。フォルダ全体からのメッセージは 1 つのデータベース ファイルに保存され、新しいメッセージはファイルの末尾に追加されます。多くのアプリケーションと API が、Apple Mail や Mozilla Thunderbird などの MBox ファイル形式をサポートしています。&lt;/p&gt;&#10;&lt;h2 id="mbox-ファイル形式"&gt;MBOX ファイル形式&lt;a class="anchor" href="#mbox-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;MBox ファイル形式は、2005 年にアプリケーション/mbox が &lt;a href="https://tools.ietf.org/rfc/rfc4155.txt"&gt;RFC 4155.&lt;/a&gt; として標準化されるまで、かなり長い間標準化されていませんでした。RFC 2822 形式のメッセージ、MBox ファイル形式内で次々に連結されます。各メッセージは、メッセージの送信者を識別する区切り線で始まり、メッセージが最終受信者 (転送パスの最後のホップ システム、または受信者として機能するシステム) によって受信された日付と時刻も識別します。メールストア）。通常、各メッセージは空行で終了します。データベースの終わりは通常、追加データがないか、明示的なファイルの終わりマーカーの存在によって認識されます。&lt;/p&gt;&#10;&lt;h2 id="mbox-ファイルからのメッセージの読み取り"&gt;MBox ファイルからのメッセージの読み取り&lt;a class="anchor" href="#mbox-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e3%81%8b%e3%82%89%e3%81%ae%e3%83%a1%e3%83%83%e3%82%bb%e3%83%bc%e3%82%b8%e3%81%ae%e8%aa%ad%e3%81%bf%e5%8f%96%e3%82%8a" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;リーダーは mbox ファイルをスキャンして From_ 行を探します。 From_ 行は、メッセージの開始を示します。読者は、すべての From_ 行 (ファイルの先頭以降) が空白行であるという事実を利用しようとしないでください。リーダーがメッセージを見つけると、(破損している可能性がある) エンベロープ送信者と配信日を From_ 行から抽出します。次に、次の From_ 行またはファイルの終わりのいずれか早い方まで読み取ります。最後の空白行を取り除き、&amp;gt;From_ 行や &amp;raquo;From_ 行などの引用を削除します。結果は RFC 822 メッセージです。&lt;/p&gt;&#10;&lt;h2 id="エンコーディングに関する考慮事項"&gt;エンコーディングに関する考慮事項&lt;a class="anchor" href="#%e3%82%a8%e3%83%b3%e3%82%b3%e3%83%bc%e3%83%87%e3%82%a3%e3%83%b3%e3%82%b0%e3%81%ab%e9%96%a2%e3%81%99%e3%82%8b%e8%80%83%e6%85%ae%e4%ba%8b%e9%a0%85" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;受信した電子メールに添付ファイルとして Mbox ファイルが含まれており、別の Mbox ファイルに保存されている場合、MBox ファイルの内容が不可逆的に混在する可能性があります。これを回避するには、メッセージング システムは、そのようなオブジェクトがメッセージング プロトコル経由で転送されるときは常に、非透過的な転送エンコーディング (BASE64 や Quoted-Printable など) を使用して mbox データベースをエンコードする必要があります。実装者は、準拠していないデータが受信された場合に mbox データをローカルでエンコードする準備をする必要もあります。&lt;/p&gt;</description></item><item><title>MSG - Microsoft Outlook 電子メール形式</title><link>https://www.aspose.info/ja/email/msg/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/msg/</guid><description>&lt;h2 id="msg-オプション番号"&gt;.MSG オプション番号&lt;a class="anchor" href="#msg-%e3%82%aa%e3%83%97%e3%82%b7%e3%83%a7%e3%83%b3%e7%95%aa%e5%8f%b7" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;MSG は、&lt;a href="https://products.office.com/en-us/outlook/email-and-calendar-software-microsoft-outlook?rtc#1"&gt;Microsoft Outlook&lt;/a&gt; および Exchange で電子メール メッセージを保存するために使用されるファイル形式です。 、連絡先、予定、またはその他のタスク。このようなメッセージには、送信者、受信者、件名、日付、およびメッセージ本文、または連絡先情報、予定の詳細、および 1 つまたは複数のタスク仕様を含む 1 つまたは複数の電子メール フィールドが含まれる場合があります。 Message オブジェクトを構成するプロパティも、MSG ファイルの一部です。 MSG ファイルには、ヘッダー、メイン メッセージ本文、およびハイパーリンクがプレーン ASCII テキストとして含まれています。 MSG ファイルは、Microsoft の Messaging Applications Programming Interface (MAPI) を必要とするプログラムにも適しています。&lt;/p&gt;&#10;&lt;h2 id="msg-ファイル構造"&gt;MSG ファイル構造&lt;a class="anchor" href="#msg-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e6%a7%8b%e9%80%a0" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;CFB_3 形式は MSG ファイルのベースです。このパラダイムは、ストレージとストリームの概念に基づいており、ディレクトリとファイルに非常に近いものです。したがって、前者の主な違いは、複合ファイルと呼ばれる別個のファイルにパッケージ化された階層全体です。オブジェクトはメッセージ ファイルを構成し、単一のプロパティまたはそのコレクションで構成されます。この機能により、アプリケーションは複雑な構造化データを 1 つのファイルに簡単に格納できます。この形式は複数のストレージも指定します。各ストレージは Message オブジェクトを主要コンポーネントとして表します。これらのストレージには、そのコンポーネントのプロパティを表す多数のストリームが含まれています。収納のネスティングも可能です。&lt;/p&gt;&#10;&lt;h2 id="マピ-プロパティ"&gt;マピ プロパティ&lt;a class="anchor" href="#%e3%83%9e%e3%83%94-%e3%83%97%e3%83%ad%e3%83%91%e3%83%86%e3%82%a3" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;.msg ファイルの最上位にあるストレージには、プロパティを格納するストリームが含まれています。プロパティは次のように分類できます。&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;固定長のプロパティ&lt;/li&gt;&#10;&lt;li&gt;可変長プロパティ&lt;/li&gt;&#10;&lt;li&gt;多値プロパティ&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;カテゴリに関係なく、プロパティはタグ付きまたは名前付きです。ただし、マッピング ストレージによって指定された名前付きプロパティには、適切なマッピング情報が必要です。&lt;/p&gt;&#10;&lt;h2 id="倉庫"&gt;倉庫&lt;a class="anchor" href="#%e5%80%89%e5%ba%ab" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ストレージは、Message オブジェクトの主要コンポーネントを構成します。 MSG ファイル形式には、次のストレージが記載されています。&lt;/p&gt;&#10;&lt;h2 id="トップレベルの構造"&gt;トップレベルの構造&lt;a class="anchor" href="#%e3%83%88%e3%83%83%e3%83%97%e3%83%ac%e3%83%99%e3%83%ab%e3%81%ae%e6%a7%8b%e9%80%a0" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;メッセージ オブジェクトは、MSG ファイル形式のトップ レベル全体を表します。タイプ、プロパティ、受信者および添付オブジェクトの数に応じて、メッセージ オブジェクトは対応する .MSG ファイルに異なるストリーム ストレージを持つことができます。&lt;/p&gt;</description></item><item><title>OFT - Microsoft Outlook 電子メール テンプレート ファイル</title><link>https://www.aspose.info/ja/email/oft/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/oft/</guid><description>&lt;h2 id="oft-オプション番号"&gt;.OFT オプション番号&lt;a class="anchor" href="#oft-%e3%82%aa%e3%83%97%e3%82%b7%e3%83%a7%e3%83%b3%e7%95%aa%e5%8f%b7" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;拡張子が .oft のファイルは、Microsoft Outlook を使用して作成されたテンプレート ファイルです。メッセージ テンプレート用に設定された書式設定済みのレイアウトは、時間を節約するために共通情報を含む電子メールの送信に使用されます。このようなファイルは、新しい電子メールを作成し、必要な情報を追加してから、Microsoft Outlook の [Office テンプレートとして保存 (.oft)] ドロップダウンを使用して生成できます。ユーザーは OFT ファイルをダブルクリックして開くことができ、その特定のシステムの関連アプリケーションで開きます。&lt;/p&gt;&#10;&lt;h2 id="oft-ファイル構造"&gt;OFT ファイル構造&lt;a class="anchor" href="#oft-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e6%a7%8b%e9%80%a0" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;.OFT ファイル形式は、&lt;a href="https://www.aspose.info/ja/email/msg/"&gt;MSG&lt;/a&gt; ファイル形式をベースに使用します。唯一の違いは、OFT ファイルは CLSID_TemplateMessage ({0006F046-0000-0000-C000-000000000046}) をストレージ クラス (WriteClassStg) として持つのに対し、MSG ファイルは CLSID_MailMessage ({00020D0B-0000-0000-C000-000000000046}) を使用することです。&lt;/p&gt;&#10;&lt;p&gt;CFB_3 形式は MSG ファイルのベースです。このパラダイムは、ストレージとストリームの概念に基づいており、ディレクトリとファイルに非常に近いものです。したがって、前者の主な違いは、複合ファイルと呼ばれる別個のファイルにパッケージ化された階層全体です。オブジェクトはメッセージ ファイルを構成し、単一のプロパティまたはそのコレクションで構成されます。この機能により、アプリケーションは複雑な構造化データを 1 つのファイルに簡単に格納できます。この形式は複数のストレージも指定します。各ストレージは Message オブジェクトを主要コンポーネントとして表します。これらのストレージには、そのコンポーネントのプロパティを表す多数のストリームが含まれています。収納のネスティングも可能です。&lt;/p&gt;&#10;&lt;h3 id="oft-プロパティ"&gt;OFT プロパティ&lt;a class="anchor" href="#oft-%e3%83%97%e3%83%ad%e3%83%91%e3%83%86%e3%82%a3" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;.msg ファイルの最上位にあるストレージには、プロパティを格納するストリームが含まれています。プロパティは次のように分類できます。&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;固定長のプロパティ&lt;/li&gt;&#10;&lt;li&gt;可変長プロパティ&lt;/li&gt;&#10;&lt;li&gt;多値プロパティ&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;カテゴリに関係なく、プロパティはタグ付きまたは名前付きのいずれかです。ただし、マッピング ストレージによって指定された名前付きプロパティには、適切なマッピング情報が必要です。&lt;/p&gt;&#10;&lt;h3 id="oft-ストレージ"&gt;OFT ストレージ&lt;a class="anchor" href="#oft-%e3%82%b9%e3%83%88%e3%83%ac%e3%83%bc%e3%82%b8" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;ストレージは、Message オブジェクトの主要コンポーネントを構成します。 MSG ファイル形式には、次のストレージが記載されています。&lt;/p&gt;&#10;&lt;h3 id="トップレベルの構造"&gt;トップレベルの構造&lt;a class="anchor" href="#%e3%83%88%e3%83%83%e3%83%97%e3%83%ac%e3%83%99%e3%83%ab%e3%81%ae%e6%a7%8b%e9%80%a0" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;Message オブジェクトは、Msg ファイル形式のトップ レベル全体を表します。タイプ、プロパティ、受信者および添付オブジェクトの数に応じて、メッセージ オブジェクトは対応する .MSG ファイルに異なるストリーム ストレージを持つことができます。&lt;/p&gt;</description></item><item><title>OLM - Outlook for Mac ファイル形式</title><link>https://www.aspose.info/ja/email/olm/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/olm/</guid><description>&lt;h2 id="olm-オプション番号"&gt;.OLM オプション番号&lt;a class="anchor" href="#olm-%e3%82%aa%e3%83%97%e3%82%b7%e3%83%a7%e3%83%b3%e7%95%aa%e5%8f%b7" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;拡張子が .olm のファイルは、Mac オペレーティング システム用の Microsoft Outlook ファイルです。 OLM ファイルには、電子メール メッセージ、ジャーナル、カレンダー データ、およびその他の種類のアプリケーション データが格納されます。これらは、Windows オペレーティング システムの Outlook で使用される &lt;a href="https://www.aspose.info/ja/email/pst/"&gt;PST&lt;/a&gt; ファイルに似ています。ただし、Outlook for Mac で作成された OLM ファイルは、Outlook for Windows では開くことができません。 OLM ファイル形式は、Outlook のローカル データを保存するために Outlook 2011 で導入されました。 1 つの OLM ファイルに複数のメールボックスを含めることができ、フォルダーとサブフォルダーの形式でデータを整理します。 OLM ファイルは、Microsoft Outlook 365 および Outlook for Mac で開く/読み込むことができます。&lt;/p&gt;&#10;&lt;h2 id="olm-ファイル形式"&gt;OLM ファイル形式&lt;a class="anchor" href="#olm-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;OLM は、Application/octet-stream MIME タイプのバイナリ ファイルです。 OLM ファイル形式の技術仕様は Microsoft から公開されておらず、開発者が参照できる形式の詳細はありません。ただし、OLM ファイル フォーマットを読み取って PST ファイルに書き込み、Aspose.Email などの Microsoft Windows オペレーティング システムで使用できる API がいくつかあります。&lt;/p&gt;</description></item><item><title>OST - Outlook ストレージ ファイル形式</title><link>https://www.aspose.info/ja/email/ost/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/ost/</guid><description>&lt;h2 id="ost-ファイルとは"&gt;.OST ファイルとは?&lt;a class="anchor" href="#ost-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e3%81%a8%e3%81%af" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;OST またはオフライン ストレージ ファイルは、Microsoft Outlook を使用して Exchange Server に登録すると、ローカル マシン上のオフライン モードでのユーザーのメールボックス データを表します。サーバーとの接続時に Microsoft Outlook を初めて使用するときに自動的に作成されます。ファイルが作成されると、データは電子メール サーバーと同期されるため、電子メール サーバーから切断された場合でもオフラインで使用できます。 OST ファイルは、電子メール、連絡先、カレンダー情報、メモ、タスク、およびその他の同様のデータなどのメールボックス アイテムを使用できます。ユーザーは、サーバーに接続していない場合でも OST ファイルに電子メールやその他のデータ項目を作成できますが、これらはサーバーと同期されません。接続が確立されると、サーバーとローカル コピーの両方が同じレベルの情報になるように、ローカル ファイルがサーバーと再び同期されます。&lt;/p&gt;&#10;&lt;h2 id="ost-ファイル形式"&gt;OST ファイル形式&lt;a class="anchor" href="#ost-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;OST (Offline Storage Table) および &lt;a href="https://www.aspose.info/ja/email/pst/"&gt;PST&lt;/a&gt; (Personal Storage Table) ファイル形式は、ユーザーの電子メール、連絡先、および予定の保存に対応する Personal Folder File (PFF) 形式で構成されます。 PFF ファイルのデータはリトルエンディアンで保存され、すべての日付と時刻は UTC の FILETIME として表されます。 [MS-PST] では、次の 2 種類の PFF が定義されています。&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;32 ビット ANSI 形式&lt;/li&gt;&#10;&lt;li&gt;64 ビット Unicode 形式&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;Microsoft から入手可能な PST ファイル形式 &lt;a href="https://learn.microsoft.com/en-us/openspecs/office_file_formats/ms-pst/141923d5-15ab-4ef1-a524-6dce75aae546"&gt;仕様&lt;/a&gt; は、OST ファイル形式にも無料で適用されます。 Open Specification Promise による取り消し不能な特許ライセンス。これは、次の特徴的な要素で構成されています。&lt;/p&gt;</description></item><item><title>PST - Outlook Personal Information Store ファイル形式</title><link>https://www.aspose.info/ja/email/pst/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/pst/</guid><description>&lt;h2 id="pst-ファイルとは何ですか"&gt;PST ファイルとは何ですか?&lt;a class="anchor" href="#pst-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e3%81%a8%e3%81%af%e4%bd%95%e3%81%a7%e3%81%99%e3%81%8b" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;拡張子が .pst のファイルは、さまざまなユーザー情報を格納する Outlook 個人用記憶域ファイル (個人用記憶域テーブルとも呼ばれます) を表します。ユーザー情報は、電子メール、予定表アイテム、メモ、連絡先、およびその他のいくつかのファイル形式を含むさまざまな種類のフォルダーに保存されます。 PST ファイルは、電子メール データをオフラインでアーカイブするために使用され、後でさまざまなアプリケーションで読み込んで表示できます。&lt;/p&gt;&#10;&lt;h2 id="pst-ファイル形式の仕様"&gt;PST ファイル形式の仕様&lt;a class="anchor" href="#pst-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f%e3%81%ae%e4%bb%95%e6%a7%98" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;PST ファイル形式 &lt;a href="https://learn.microsoft.com/en-us/openspecs/office_file_formats/ms-pst/141923d5-15ab-4ef1-a524-6dce75aae546"&gt;仕様&lt;/a&gt; は、Microsoft から、Open Specification Promise を通じて無料かつ取消不能な無料の特許ライセンスとして入手できます。 .&lt;/p&gt;&#10;&lt;h3 id="pst-形式の種類"&gt;PST 形式の種類&lt;a class="anchor" href="#pst-%e5%bd%a2%e5%bc%8f%e3%81%ae%e7%a8%ae%e9%a1%9e" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;PST ファイル形式は、ファイル タイプのエンコーディングに基づいて 2 つのタイプに分類されます。 ANSI でエンコードされた PST ファイルは古いファイル形式であり、Outlook 2002 以前のバージョンでのみサポートされています。このようなファイルの最大サイズは 2 GB (2^^31^^ バイト) に制限されており、Unicode はサポートされていません。 Unicode エンコーディングに基づく、より最新のファイル形式タイプでは、ファイル サイズの制限がなくなり、最大データ サイズが 50 GB に達する可能性があります。&lt;/p&gt;&#10;&lt;h3 id="pst-ファイル形式の論理構成"&gt;PST ファイル形式の論理構成&lt;a class="anchor" href="#pst-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f%e3%81%ae%e8%ab%96%e7%90%86%e6%a7%8b%e6%88%90" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;PST ファイル形式の基盤には B ツリーがあり、データを並べ替え、検索、順次アクセス、挿入、削除などを対数時間で実行できます。 PST ファイルの全体的な構造は、3 つの層で構成されています。&lt;/p&gt;&#10;&lt;p&gt;&lt;img src="https://www.aspose.info/email/PST-1.png" alt="Logical layers of a PST file" title="Logical layers of a PST file"&gt;&lt;/p&gt;</description></item><item><title>RPMSG ファイル - Outlook 制限付きアクセス許可メッセージ ファイル</title><link>https://www.aspose.info/ja/email/rpmsg/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/rpmsg/</guid><description>&lt;h2 id="rpmsg-オプション番号"&gt;.RPMSG オプション番号&lt;a class="anchor" href="#rpmsg-%e3%82%aa%e3%83%97%e3%82%b7%e3%83%a7%e3%83%b3%e7%95%aa%e5%8f%b7" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;RPMSG ファイルは、電子メール クライアント アプリケーション Microsoft Outlook、Microsoft の電子メールおよびカレンダー アプリケーションで作成された暗号化された電子メール メッセージです。これは、標準の電子メール メッセージに別の添付ファイルとして送信され、特定のユーザーのみが開くことができます。これにより、これらのファイル内の情報を受け取る予定のない他のユーザーに、これらのファイルへのアクセスが制限されます。通常、これらのファイルは message.rpmsg というファイル名で送信され、電子メールからもダウンロードできますが、この場合は機能しません。&lt;/p&gt;&#10;&lt;h2 id="rpmsg-ファイル形式"&gt;RPMSG ファイル形式&lt;a class="anchor" href="#rpmsg-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;RPMSG ファイルは、バイナリ ファイル形式でディスクに保存されます。ただし、そのファイル形式の仕様は、暗号化されているため、開発者が参照できるように公開されていません。&lt;/p&gt;&#10;&lt;h2 id="参考文献"&gt;参考文献&lt;a class="anchor" href="#%e5%8f%82%e8%80%83%e6%96%87%e7%8c%ae" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;&lt;a href="https://outlook.live.com/owa/"&gt;Microsoft Outlook&lt;/a&gt;&lt;/li&gt;&#10;&lt;/ul&gt;</description></item><item><title>TNEF</title><link>https://www.aspose.info/ja/email/tnef/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/tnef/</guid><description>&lt;h2 id="tnef-オプション番号"&gt;.TNEF オプション番号&lt;a class="anchor" href="#tnef-%e3%82%aa%e3%83%97%e3%82%b7%e3%83%a7%e3%83%b3%e7%95%aa%e5%8f%b7" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;Transport Neutral Encapsulation Format (TNEF) は Microsoft 独自のもので、Messaging Application Programming Interface (&lt;strong&gt;MAPI&lt;/strong&gt;) に基づいて電子メールの添付ファイルをカプセル化します。 Microsoft Outlook と Microsoft Exchange Server は TNEF を完全にサポートしますが、後で TNEF を MAPI にデコードし、フォーマットされたメールを表示します。 TNEF エンコーディングの電子メール添付ファイルは、MS-TNEF の MIME タイプを持ち、winmail/win.dat として保存されます。 winmail .dat の添付ファイルには、次の情報がカプセル化されています。&lt;/p&gt;&#10;&lt;table&gt;&#10;&#9;&lt;thead&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;メッセージ&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;OLE オブジェクト&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;Outlook の機能&lt;/th&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/thead&gt;&#10;&#9;&lt;tbody&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;元のメッセージの添付ファイル&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;元のフォーマットされたバージョン&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;フォント、テキスト サイズ、およびテキストの色&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/tbody&gt;&#10;&lt;/table&gt;&#10;&lt;p&gt;TNEF をサポートしていないその他の電子メール サービスでは、TNEF 形式のメッセージにプレーン テキストが表示されます。 Outlook は、リッチ フォーマットのメッセージを TNEF ファイル (OLE) または特定の Outlook 機能 (フォーム、投票ボタン、会議出席依頼) に埋め込みます。 Outlook 電子メール クライアント内で明示的な TNEF エンコーディングを許可することはできませんが、電子メールの送信に RTF 形式を選択すると、暗黙的に TNEF エンコーディングが容易になります。&lt;/p&gt;</description></item><item><title>VCF - 仮想連絡先ファイル</title><link>https://www.aspose.info/ja/email/vcf/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/ja/email/vcf/</guid><description>&lt;h2 id="vcf-オプション番号"&gt;.VCF オプション番号&lt;a class="anchor" href="#vcf-%e3%82%aa%e3%83%97%e3%82%b7%e3%83%a7%e3%83%b3%e7%95%aa%e5%8f%b7" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;VCF (Virtual Card Format) または vCard は、連絡先情報を保存するためのデジタル ファイル形式です。この形式は、一般的な情報交換アプリケーション間のデータ交換に広く使用されています。 Windows や MacOS などのほとんどのオペレーティング システムには、これらのファイルを作成して開くための既定のアプリケーションが付属しています。 1 つの VCF ファイルには、1 つまたは複数の連絡先の連絡先情報を含めることができます。通常、VCF ファイルには、連絡先の名前、住所、電話番号、電子メール、誕生日、写真、音声などの情報に加えて、他の多くのフィールドが含まれています。メール クライアントとサービスでサポートされているため、vCard 形式を使用して連絡先を転送する際にデータが失われることはありません。 VCF ファイル形式のメディア タイプは text/vcard です。&lt;/p&gt;&#10;&lt;h2 id="vcf-ファイル形式"&gt;VCF ファイル形式&lt;a class="anchor" href="#vcf-%e3%83%95%e3%82%a1%e3%82%a4%e3%83%ab%e5%bd%a2%e5%bc%8f" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;VCF ファイルは本質的にテキストであり、人間が判読できます。これらは、Microsoft Windows のメモ帳や MacOS の TextEdit などのテキスト エディターで開くことができます。ただし、ファイルに画像がある場合、テキスト エディターには表示されません。&lt;/p&gt;&#10;&lt;p&gt;&lt;a href="https://support.office.com/en-us/article/send-and-save-contacts-as-vcards-vcf-files-94a17a6f-105f-46c7-9308-33658c1c2690"&gt;Microsoft Outlook&lt;/a&gt; は、 VCF ファイルを開くだけでなく、一般的な &lt;a href="https://www.aspose.info/ja/email/msg/"&gt;MSG&lt;/a&gt; 形式など、他の多くの形式に変換することもできます。 VCF ファイル形式は、バージョン 2.1 から 4.0 までの時間とともに強化され、ファイル形式に詳細な情報が追加されました。この形式は、電話の連絡先をエクスポートし、後で別のデバイスにインポートするためにも使用されます。&lt;/p&gt;&#10;&lt;figure&gt;&lt;img src="../VCF.png"&#10;&#9;&#9;&#9;alt="VCF ファイル形式"&gt;&#10;&lt;/figure&gt;&#10;&#10;&lt;h3 id="vcf-21-の例"&gt;VCF 2.1 の例&lt;a class="anchor" href="#vcf-21-%e3%81%ae%e4%be%8b" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;以下は、バージョン 2.1 の例です。&lt;/p&gt;&#10;&lt;pre tabindex="0"&gt;&lt;code&gt;BEGIN:VCARD&#10;VERSION:2.1&#10;N:Gump;Forrest;;Mr.&#10;FN:Forrest Gump&#10;ORG:Bubba Gump Shrimp Co.&#10;TITLE:Shrimp Man&#10;PHOTO;GIF:http://www.example.com/dir_photos/my_photo.gif&#10;TEL;WORK;VOICE:(111) 555-1212&#10;TEL;HOME;VOICE:(404) 555-1212&#10;ADR;WORK;PREF:;;100 Waters Edge;Baytown;LA;30314;United States of America&#10;LABEL;WORK;PREF;ENCODING#QUOTED-PRINTABLE;CHARSET#UTF-8:100 Waters Edge#0D#&#10; #0ABaytown\, LA 30314#0D#0AUnited States of America&#10;ADR;HOME:;;42 Plantation St.;Baytown;LA;30314;United States of America&#10;LABEL;HOME;ENCODING#QUOTED-PRINTABLE;CHARSET#UTF-8:42 Plantation St.#0D#0A#&#10; Baytown, LA 30314#0D#0AUnited States of America&#10;EMAIL:forrestgump@example.com&#10;REV:20080424T195243Z&#10;END:VCARD&#10;&lt;/code&gt;&lt;/pre&gt;&lt;h3 id="vcf-30-の例"&gt;VCF 3.0 の例&lt;a class="anchor" href="#vcf-30-%e3%81%ae%e4%be%8b" aria-label="このセクションへのリンクをコピー"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;以下は、バージョン 3.0 の例です。&lt;/p&gt;</description></item></channel></rss>