<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom"><channel><title>เรียนรู้เกี่ยวกับรูปแบบไฟล์อีเมลและ API ที่สามารถเปิดและสร้างไฟล์อีเมล on aspose.info</title><link>https://www.aspose.info/th/email/</link><description>Recent content in เรียนรู้เกี่ยวกับรูปแบบไฟล์อีเมลและ API ที่สามารถเปิดและสร้างไฟล์อีเมล on aspose.info</description><generator>Hugo</generator><language>th</language><lastBuildDate>Mon, 31 Jan 2022 00:00:00 +0000</lastBuildDate><atom:link href="https://www.aspose.info/th/email/index.xml" rel="self" type="application/rss+xml"/><item><title>ไฟล์ P7S - ข้อความอีเมลที่เซ็นชื่อแบบดิจิทัล</title><link>https://www.aspose.info/th/email/p7s/</link><pubDate>Mon, 31 Jan 2022 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/p7s/</guid><description>&lt;h2 id="ไฟล-p7s-คออะไร"&gt;ไฟล์ P7S คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-p7s-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ P7S เป็นลายเซ็นดิจิทัลที่ได้รับพร้อมกับอีเมลที่เซ็นชื่อแบบดิจิทัล การมีอยู่ของไฟล์นี้เป็นสิ่งที่แนบมากับอีเมลเป็นการยืนยันว่าอีเมลนั้นถูกส่งมาจากแหล่งที่มาที่แท้จริง สิ่งนี้ทำให้มั่นใจได้ว่าผู้ส่งมีใบรับรองการเซ็นชื่ออีเมลติดตั้งอยู่ในคอมพิวเตอร์ เมื่ออีเมลที่ลงชื่อแล้วถูกส่งจากคอมพิวเตอร์ของผู้ใช้ ไฟล์ P7S จะถูกแนบมาพร้อมกับอีเมลที่มีชื่อผู้ส่ง ไคลเอนต์อีเมลที่รองรับอีเมลที่ลงนามแล้วสามารถดูข้อมูลของผู้ส่งได้&lt;/p&gt;&#10;&lt;h2 id="รปแบบไฟล-p7s---ขอมลเพมเตม"&gt;รูปแบบไฟล์ P7S - ข้อมูลเพิ่มเติม&lt;a class="anchor" href="#%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-p7s---%e0%b8%82%e0%b8%ad%e0%b8%a1%e0%b8%a5%e0%b9%80%e0%b8%9e%e0%b8%a1%e0%b9%80%e0%b8%95%e0%b8%a1" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ S/MIME (Secure/Multipurpose Internet Mail Extensions) P7S มีข้อมูลในรูปแบบข้อความล้วนที่มนุษย์สามารถอ่านได้ ไคลเอนต์อีเมล เช่น Microsoft Outlook, Apple Mail และ Mozilla Thunderbird รองรับการอ่านข้อมูลที่เซ็นชื่อแบบดิจิทัลจากอีเมล S/MIME การลงชื่อในอีเมลเป็นการยืนยันตัวตนของผู้ส่งและบอกผู้รับว่าข้อความนั้นเป็นของจริง เมื่อดาวน์โหลดอีเมลจากไคลเอ็นต์อีเมล (ไม่ว่าจะเป็น &lt;a href="https://www.aspose.info/th/email/eml/"&gt;EML&lt;/a&gt; หรือ &lt;a href="https://www.aspose.info/th/email/msg/"&gt;MSG&lt;/a&gt;) ไฟล์ P7S เหล่านี้จะถูกแนบมากับอีเมลเหล่านี้&lt;/p&gt;&#10;&lt;p&gt;ไฟล์ P7S มีข้อมูลต่อไปนี้:&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;แหล่งที่มาของที่มาของอีเมล&lt;/li&gt;&#10;&lt;li&gt;วันที่และเวลาที่ส่ง&lt;/li&gt;&#10;&lt;li&gt;ไม่ว่าจะได้รับการแก้ไขระหว่างการส่ง&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;ข้อมูลนี้ถูกฝังโดยใช้เทคโนโลยี Public-Key Cryptography Standard #7 (PKCS7) สำหรับการแนบลายเซ็นที่เข้ารหัสแบบดิจิทัลกับอีเมล&lt;/p&gt;&#10;&lt;h2 id="อางอง"&gt;อ้างอิง&lt;a class="anchor" href="#%e0%b8%ad%e0%b8%b2%e0%b8%87%e0%b8%ad%e0%b8%87" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;&lt;a href="https://learn.microsoft.com/en-us/windows-hardware/drivers/devtest/signtool"&gt;เครื่องมือลงชื่อเข้าใช้ของ Microsoft&lt;/a&gt;&lt;/li&gt;&#10;&lt;/ul&gt;</description></item><item><title>รูปแบบไฟล์ EDB - ไฟล์ฐานข้อมูล Exchange Mail</title><link>https://www.aspose.info/th/email/edb/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/edb/</guid><description>&lt;h2 id="ไฟล-edb-คออะไร"&gt;ไฟล์ EDB คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-edb-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ที่มีนามสกุลไฟล์ .edb เป็นฐานข้อมูลเมลบ็อกซ์ที่สร้างโดย Microsoft Exchange Server เพื่อเก็บข้อมูลเกี่ยวกับเมล EDB, Exchange Database จัดเก็บข้อความที่อยู่ระหว่างดำเนินการและไม่ใช่ SMTP EDB เรียกอีกอย่างว่าไฟล์ฐานข้อมูล Extensible Storage Engine (ESE) และจัดเก็บไฟล์โดยใช้โครงสร้าง b-tree ในฐานะที่เป็นไฟล์จัดเก็บ ไฟล์ EDB สามารถแปลงเป็นรูปแบบไฟล์จัดเก็บเมลอื่นๆ เช่น &lt;a href="https://www.aspose.info/th/email/pst/"&gt;PST&lt;/a&gt; และ &lt;a href="https://www.aspose.info/th/email/ost/"&gt;OST&lt;/a&gt;&lt;/p&gt;&#10;&lt;h2 id="รปแบบไฟล-edb"&gt;รูปแบบไฟล์ EDB&lt;a class="anchor" href="#%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-edb" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไม่มีข้อมูลจำเพาะรูปแบบไฟล์ EDB ที่เป็นทางการ/เปิดที่สามารถอ้างอิงได้ มีความคืบหน้าบางอย่างสำหรับการทำวิศวกรรมย้อนกลับรูปแบบไฟล์ ส่งผลให้มีการถอดรหัสข้อมูลจำเพาะบางส่วน ไฟล์ EDB ประกอบด้วย:&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;ส่วนหัวของไฟล์ - มีข้อมูลส่วนหัวของไฟล์ฐานข้อมูล&lt;/li&gt;&#10;&lt;li&gt;หน้าขนาดคงที่ - มีฐานข้อมูลซึ่งประกอบด้วยตารางและดัชนี&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;h3 id="สวนหวของไฟลฐานขอมล"&gt;ส่วนหัวของไฟล์ฐานข้อมูล&lt;a class="anchor" href="#%e0%b8%aa%e0%b8%a7%e0%b8%99%e0%b8%ab%e0%b8%a7%e0%b8%82%e0%b8%ad%e0%b8%87%e0%b9%84%e0%b8%9f%e0%b8%a5%e0%b8%90%e0%b8%b2%e0%b8%99%e0%b8%82%e0%b8%ad%e0%b8%a1%e0%b8%a5" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;ส่วนหัวของไฟล์ฐานข้อมูลอยู่ในหน้าฐานข้อมูลแรกและมีขนาดอย่างน้อย 668 ไบต์ ส่วนหัวของไฟล์ประกอบด้วย `File Format Version&amp;rsquo; และ &amp;lsquo;File Type&amp;rsquo; นอกเหนือจากฟิลด์อื่นๆ&lt;/p&gt;&#10;&lt;h4 id="ประเภทไฟล"&gt;ประเภทไฟล์&lt;a class="anchor" href="#%e0%b8%9b%e0%b8%a3%e0%b8%b0%e0%b9%80%e0%b8%a0%e0%b8%97%e0%b9%84%e0%b8%9f%e0%b8%a5" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h4&gt;&#10;&lt;table&gt;&#10;&#9;&lt;thead&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;ประเภท&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;คำอธิบาย&lt;/th&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/thead&gt;&#10;&#9;&lt;tbody&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;ฐานข้อมูล&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;สตรีมมิ่ง&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/tbody&gt;&#10;&lt;/table&gt;&#10;&lt;p&gt;&lt;code&gt;หมายเหตุ:&lt;/code&gt; ไม่รู้จักตัวระบุสำหรับประเภทเหล่านี้&lt;/p&gt;</description></item><item><title>EML - ข้อความอีเมล</title><link>https://www.aspose.info/th/email/eml/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/eml/</guid><description>&lt;h2 id="ไฟล-eml-คออะไร"&gt;ไฟล์ EML คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-eml-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;รูปแบบไฟล์ EML แสดงถึงข้อความอีเมลที่บันทึกโดยใช้ Outlook และแอปพลิเคชันอื่นๆ ที่เกี่ยวข้อง ไคลเอนต์อีเมลเกือบทั้งหมดรองรับรูปแบบไฟล์นี้เนื่องจากเป็นไปตามมาตรฐานรูปแบบข้อความอินเทอร์เน็ต RFC-822 Microsoft Outlook เป็นซอฟต์แวร์เริ่มต้นสำหรับการเปิดประเภทข้อความ EML สามารถใช้ไฟล์ EML เพื่อบันทึกลงดิสก์และส่งออกไปยังผู้รับโดยใช้โปรโตคอลการสื่อสาร&lt;/p&gt;&#10;&lt;h2 id="ประวตโดยยอของ-eml"&gt;ประวัติโดยย่อของ EML&lt;a class="anchor" href="#%e0%b8%9b%e0%b8%a3%e0%b8%b0%e0%b8%a7%e0%b8%95%e0%b9%82%e0%b8%94%e0%b8%a2%e0%b8%a2%e0%b8%ad%e0%b8%82%e0%b8%ad%e0%b8%87-eml" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ข้อกำหนดรูปแบบไฟล์ EML มีอยู่ในรูปแบบมาตรฐาน &lt;a href="https://www.ietf.org/rfc/rfc0822.txt"&gt;RFC 822&lt;/a&gt; ก่อน RFC-822, RFC-733 ควบคุมกฎการแลกเปลี่ยนข้อความเครือข่ายจนกระทั่งในปี 1982 กฎเดิมถูกสร้างขึ้นเพื่อปรับปรุงด้านข้างโดยสร้างมาตรฐาน ARPA ในเวลาเดียวกัน Microsoft ได้สร้างโมดูล COM ของตนเองสำหรับการพัฒนาไคลเอ็นต์อีเมลของตนเอง เช่น Outlook Express RFC-822 ใช้เส้นทางเพื่อสร้างเป็นรูปแบบกรรมสิทธิ์เมื่อ Microsoft เบี่ยงเบนจากมาตรฐานเปิดและสร้างรูปแบบไฟล์ &lt;a href="https://www.aspose.info/th/email/pst/"&gt;PST&lt;/a&gt; ซึ่งอีเมลจะถูกบันทึกในรูปแบบฐานข้อมูลที่มีโครงสร้างสูง สิ่งนี้ส่งผลให้เกิดปัญหาสำหรับผู้ใช้ไคลเอ็นต์อีเมลที่ไม่ใช่ของ Microsoft เมื่ออีเมลถูกส่งต่อจาก Microsoft Outlook&lt;/p&gt;&#10;&lt;p&gt;ในปี 2544 เมื่อมาตรฐาน 822 ได้รับการปรับปรุงเป็น 2822 - รูปแบบข้อความอินเทอร์เน็ต ซึ่งปัจจุบันใช้ในการสร้าง อ่าน และส่งข้อความ EML ในรูปแบบ MIME RFC-822&lt;/p&gt;&#10;&lt;h2 id="ขอมลจำเพาะรปแบบไฟล-eml"&gt;ข้อมูลจำเพาะรูปแบบไฟล์ EML&lt;a class="anchor" href="#%e0%b8%82%e0%b8%ad%e0%b8%a1%e0%b8%a5%e0%b8%88%e0%b8%b3%e0%b9%80%e0%b8%9e%e0%b8%b2%e0%b8%b0%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-eml" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ EML ประกอบด้วยสองส่วนที่แตกต่างกัน:&lt;/p&gt;</description></item><item><title>EMLX - รูปแบบไฟล์ Apple Mail</title><link>https://www.aspose.info/th/email/emlx/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/emlx/</guid><description>&lt;h2 id="ไฟล-emlx-คออะไร"&gt;ไฟล์ EMLX คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-emlx-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;รูปแบบไฟล์ EMLX ถูกนำมาใช้และพัฒนาโดย Apple แอปพลิเคชัน Apple Mail ใช้รูปแบบไฟล์ EMLX เพื่อส่งออกอีเมล มีแอปพลิเคชั่นอื่นที่สามารถเปิดไฟล์ EMLX และแปลงไฟล์เหล่านี้เป็นรูปแบบไฟล์อื่นได้&lt;/p&gt;&#10;&lt;h2 id="ประวตโดยยอของรปแบบไฟล-emlx"&gt;ประวัติโดยย่อของรูปแบบไฟล์ EMLX&lt;a class="anchor" href="#%e0%b8%9b%e0%b8%a3%e0%b8%b0%e0%b8%a7%e0%b8%95%e0%b9%82%e0%b8%94%e0%b8%a2%e0%b8%a2%e0%b8%ad%e0%b8%82%e0%b8%ad%e0%b8%87%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-emlx" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ระบบปฏิบัติการ Mac OS X นำโปรแกรมอีเมลที่มีอยู่ NeXTMail ซึ่งสร้างโดย NeXT เป็นส่วนหนึ่งของระบบปฏิบัติการ NeXTSTEP Apple หลังจากได้รับ NeXT ได้ยกระดับคุณสมบัติต่างๆ และกลายเป็นแอปพลิเคชันอีเมล Apple Mail ที่จะใช้เป็นโปรแกรมรับส่งอีเมลเริ่มต้น อีเมลที่ส่งออกผ่าน Apple Mail จะถูกบันทึกโดยตรงเป็นไฟล์ EMLX นอกจากนี้ยังเป็นไคลเอ็นต์อีเมลเริ่มต้นสำหรับไฟล์ EMLX เมื่อมีคนเปิดไฟล์เหล่านี้โดยดับเบิลคลิกบน Mac OS&lt;/p&gt;&#10;&lt;h2 id="รปแบบไฟล-emlx"&gt;รูปแบบไฟล์ EMLX&lt;a class="anchor" href="#%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-emlx" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ EMLx เป็นไฟล์ข้อความธรรมดาที่สามารถเปิดได้ในโปรแกรมแก้ไขข้อความใดๆ เช่น Notepad โครงสร้างไฟล์ EMLX ประกอบด้วยสามส่วน:&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;จำนวนไบต์สำหรับข้อความ - ความยาวของข้อความเอง เขียนเป็น ASCII เป็นทศนิยม สิ้นสุดด้วย 0x0a&lt;/li&gt;&#10;&lt;li&gt;ข้อความนั้นเอง&lt;/li&gt;&#10;&lt;li&gt;ข้อมูลเมตาของข้อความในรูปแบบของ XML plist&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;สิ่งเหล่านี้สามารถอธิบายได้ดีขึ้นโดยใช้ตัวอย่างอีเมลที่แยกจาก Apple Mail เป็น EMLX และเปิดในโปรแกรมแก้ไขข้อความ&lt;/p&gt;</description></item><item><title>ICS - รูปแบบไฟล์ iCalendar</title><link>https://www.aspose.info/th/email/ics/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/ics/</guid><description>&lt;h2 id="ไฟล-ics-คออะไร"&gt;ไฟล์ ICS คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-ics-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;Internet Calendaring and Scheduling Core Object Specification (iCalendar) เป็นมาตรฐานอินเทอร์เน็ต (RFC 2445) สำหรับแลกเปลี่ยนและปรับใช้กิจกรรมและการจัดกำหนดการในปฏิทิน รูปแบบ iCalendar ทำงานร่วมกันได้ ดังนั้นจึงรับประกันการแลกเปลี่ยนข้อมูลปฏิทินระหว่างผู้ใช้ที่มีแอปพลิเคชันอีเมลต่างกัน iCalendar จัดรูปแบบข้อมูลที่ป้อนเป็น Multipurpose Internet Mail Extensions (MIME) และอำนวยความสะดวกในการแลกเปลี่ยนวัตถุผ่านโปรโตคอลการขนส่งที่แตกต่างกัน โปรโตคอลการขนส่งเหล่านี้สามารถเป็น SMTP, HTTP, การสื่อสารแบบอะซิงโครนัสแบบจุดต่อจุด และการขนส่งเครือข่ายตามสื่อทางกายภาพ&lt;/p&gt;&#10;&lt;p&gt;iCalendar ช่วยให้ผู้ใช้สามารถแชร์กิจกรรม วันที่/เวลา งานที่ขึ้นกับวันที่/เวลา และข้อมูลว่าง/ไม่ว่างผ่านทางอีเมลไปยังผู้ใช้คนอื่นๆ ที่สามารถตอบกลับได้ ไฟล์ iCalendar จัดเก็บโดยใช้ส่วนต่อท้าย &amp;ldquo;.ics&amp;rdquo; &amp;ldquo;.iCalendar&amp;rdquo; หรือ &amp;ldquo;.ifb&amp;rdquo; โดยมีประเภท MIME เป็น &amp;ldquo;ข้อความ/ปฏิทิน&amp;rdquo; iCalendar ได้รับการดูแลให้พึ่งพาตนเองโดยไม่ต้องพึ่งพาโปรโตคอลการขนส่ง เว็บเซิร์ฟเวอร์ (ที่มีโปรโตคอล HTTP) สามารถส่งข้อมูล iCalendar และเว็บเพจสามารถมีข้อมูล iCalendar ในรูปแบบฝังโดยใช้ iCalendar&lt;/p&gt;&#10;&lt;h2 id="ประวตโดยยอของรปแบบไฟล-ics"&gt;ประวัติโดยย่อของรูปแบบไฟล์ ICS&lt;a class="anchor" href="#%e0%b8%9b%e0%b8%a3%e0%b8%b0%e0%b8%a7%e0%b8%95%e0%b9%82%e0%b8%94%e0%b8%a2%e0%b8%a2%e0%b8%ad%e0%b8%82%e0%b8%ad%e0%b8%87%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-ics" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ในปี 1998 Internet Engineering Task Force (IETF) ได้กำหนดให้ iCalendar เป็นมาตรฐาน (RFC 2445) มาตรฐานได้รับการจัดทำเป็นเอกสารโดย Frank Dawson (Lotus Notes Corporation) และ Derik Stenerson (Microsoft) ในปี 2009 Bernard Desruisseaux (Oracle) ได้ปรับปรุงมาตรฐานอีกครั้งเป็น RFC 5545 ครั้งนี้มีการเพิ่มคุณสมบัติใหม่และเลิกใช้งานคุณสมบัติที่ล้าสมัยบางส่วน ในปี 2559 RFC 7986 ได้รับการเผยแพร่และเพิ่มเติมให้กับ iCalendar RFC ดั้งเดิม RFC 7986 ได้เพิ่มคุณลักษณะใหม่ให้กับวัตถุ VCALENDAR หลัก และยังมีการแนะนำคุณลักษณะใหม่ที่รองรับสำหรับระบบการประชุมอีกด้วย&lt;/p&gt;</description></item><item><title>MBOX - ไฟล์กล่องจดหมายอีเมล</title><link>https://www.aspose.info/th/email/mbox/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/mbox/</guid><description>&lt;h2 id="ไฟล-mbox-คออะไร"&gt;ไฟล์ MBOX คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-mbox-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;รูปแบบไฟล์ MBox เป็นคำทั่วไปที่แสดงถึงที่เก็บสำหรับรวบรวมข้อความจดหมายอิเล็กทรอนิกส์ ข้อความจะถูกเก็บไว้ในคอนเทนเนอร์พร้อมกับไฟล์แนบ ข้อความจากทั้งโฟลเดอร์จะถูกบันทึกในไฟล์ฐานข้อมูลไฟล์เดียว และข้อความใหม่จะถูกต่อท้ายไฟล์ แอปพลิเคชันและ API จำนวนมากให้การสนับสนุนรูปแบบไฟล์ MBox เช่น Apple Mail และ Mozilla Thunderbird&lt;/p&gt;&#10;&lt;h2 id="รปแบบไฟล-mbox"&gt;รูปแบบไฟล์ MBOX&lt;a class="anchor" href="#%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-mbox" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;รูปแบบไฟล์ MBox ยังคงไม่เป็นมาตรฐานเป็นเวลานานจนกระทั่งปี 2548 เมื่อแอปพลิเคชัน/mbox ได้รับมาตรฐานเป็น &lt;a href="https://tools.ietf.org/rfc/rfc4155.txt"&gt;RFC 4155.&lt;/a&gt; Messages ในรูปแบบ RFC 2822 จะถูกเชื่อมเข้าด้วยกันในรูปแบบไฟล์ MBox ทีละไฟล์ แต่ละข้อความจะขึ้นต้นด้วยบรรทัดคั่นที่ระบุผู้ส่งข้อความ และยังระบุวันที่และเวลาที่ผู้รับคนสุดท้ายได้รับข้อความด้วย (ระบบ Last-Hop ในเส้นทางการถ่ายโอน หรือระบบที่ทำหน้าที่เป็นผู้รับ ร้านไปรษณีย์). โดยทั่วไปแต่ละข้อความจะถูกยกเลิกโดยบรรทัดว่าง จุดสิ้นสุดของฐานข้อมูลมักรับรู้ได้จากการไม่มีข้อมูลเพิ่มเติมใดๆ หรือโดยการมีเครื่องหมายจุดสิ้นสุดของไฟล์ที่ชัดเจน&lt;/p&gt;&#10;&lt;h2 id="การอานขอความจากไฟล-mbox"&gt;การอ่านข้อความจากไฟล์ MBox&lt;a class="anchor" href="#%e0%b8%81%e0%b8%b2%e0%b8%a3%e0%b8%ad%e0%b8%b2%e0%b8%99%e0%b8%82%e0%b8%ad%e0%b8%84%e0%b8%a7%e0%b8%b2%e0%b8%a1%e0%b8%88%e0%b8%b2%e0%b8%81%e0%b9%84%e0%b8%9f%e0%b8%a5-mbox" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;เครื่องอ่านสแกนผ่านไฟล์ mbox เพื่อค้นหาบรรทัด From_ บรรทัด From_ ใด ๆ ทำเครื่องหมายจุดเริ่มต้นของข้อความ ผู้อ่านไม่ควรพยายามใช้ประโยชน์จากความจริงที่ว่าทุกบรรทัด From_ (ผ่านจุดเริ่มต้นของไฟล์) บรรทัดว่าง เมื่อเครื่องอ่านพบข้อความ เครื่องจะแยกผู้ส่งซองจดหมาย (อาจเสียหาย) และวันที่ส่งออกจากบรรทัด From_ จากนั้นจะอ่านจนถึงบรรทัด From_ ถัดไปหรือจุดสิ้นสุดของไฟล์ แล้วแต่ว่าจะถึงอย่างใดก่อน มันตัดบรรทัดว่างสุดท้ายออกและลบเครื่องหมายคำพูดของ &amp;gt;From_ บรรทัดและ &amp;raquo;From_ บรรทัดและอื่นๆ ผลลัพธ์คือข้อความ RFC 822&lt;/p&gt;</description></item><item><title>ผงชูรส - รูปแบบอีเมล Microsoft Outlook</title><link>https://www.aspose.info/th/email/msg/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/msg/</guid><description>&lt;h2 id="ไฟล-msg-คออะไร"&gt;ไฟล์ MSG คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-msg-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;MSG เป็นรูปแบบไฟล์ที่ใช้โดย &lt;a href="https://products.office.com/en-us/outlook/email-and-calendar-software-microsoft-outlook?rtc#1"&gt;Microsoft Outlook&lt;/a&gt; และ Exchange เพื่อจัดเก็บข้อความอีเมล ติดต่อนัดหมายหรืองานอื่นๆ ข้อความดังกล่าวอาจมีฟิลด์อีเมลตั้งแต่หนึ่งฟิลด์ขึ้นไป โดยมีผู้ส่ง ผู้รับ หัวเรื่อง วันที่ และเนื้อความของข้อความ หรือข้อมูลติดต่อ รายละเอียดการนัดหมาย และข้อกำหนดเฉพาะของงานอย่างน้อยหนึ่งรายการ คุณสมบัติที่ประกอบขึ้นเป็นอ็อบเจกต์ Message รวมถึงเป็นส่วนหนึ่งของไฟล์ MSG ไฟล์ MSG มีส่วนหัว เนื้อหาข้อความหลัก และไฮเปอร์ลิงก์เป็นข้อความ ASCII ธรรมดา ไฟล์ MSG ยังเหมาะกับโปรแกรมที่ต้องการ Messaging Applications Programming Interface (MAPI) ของ Microsoft&lt;/p&gt;&#10;&lt;h2 id="โครงสรางไฟล-msg"&gt;โครงสร้างไฟล์ MSG&lt;a class="anchor" href="#%e0%b9%82%e0%b8%84%e0%b8%a3%e0%b8%87%e0%b8%aa%e0%b8%a3%e0%b8%b2%e0%b8%87%e0%b9%84%e0%b8%9f%e0%b8%a5-msg" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;รูปแบบ CFB_3 เป็นฐานของไฟล์ MSG กระบวนทัศน์นี้อิงตามแนวคิดของสตอเรจและสตรีม ซึ่งค่อนข้างใกล้เคียงกับไดเร็กทอรีและไฟล์ ดังนั้นความแตกต่างที่สำคัญในอดีตคือลำดับชั้นทั้งหมด ซึ่งบรรจุเป็นไฟล์ที่แตกต่างกัน เรียกว่าไฟล์ผสม อ็อบเจกต์ประกอบด้วยไฟล์ข้อความและประกอบด้วยคุณสมบัติเดียวหรือคอลเล็กชัน ความสามารถนี้ช่วยให้แอปพลิเคชันสามารถจัดเก็บข้อมูลที่มีโครงสร้างซับซ้อนไว้ในไฟล์เดียว รูปแบบนี้ยังระบุที่เก็บข้อมูลหลายที่ ซึ่งแต่ละที่เก็บข้อมูลจะแทนออบเจกต์ข้อความเป็นองค์ประกอบหลัก ที่เก็บข้อมูลเหล่านี้มีจำนวนสตรีมที่แสดงคุณสมบัติของส่วนประกอบนั้น นอกจากนี้ยังสามารถซ้อนที่เก็บข้อมูลได้อีกด้วย&lt;/p&gt;&#10;&lt;h2 id="คณสมบตของมะป"&gt;คุณสมบัติของมะปี&lt;a class="anchor" href="#%e0%b8%84%e0%b8%93%e0%b8%aa%e0%b8%a1%e0%b8%9a%e0%b8%95%e0%b8%82%e0%b8%ad%e0%b8%87%e0%b8%a1%e0%b8%b0%e0%b8%9b" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ที่ระดับบนสุดของไฟล์ .msg ที่เก็บข้อมูลประกอบด้วยสตรีมที่เก็บคุณสมบัติไว้ในนั้น สามารถแบ่งประเภทคุณสมบัติได้ดังนี้&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;คุณสมบัติความยาวคงที่&lt;/li&gt;&#10;&lt;li&gt;คุณสมบัติความยาวตัวแปร&lt;/li&gt;&#10;&lt;li&gt;คุณสมบัติหลายค่า&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;โดยไม่คำนึงถึงหมวดหมู่ พร็อพเพอร์ตี้อาจเป็นแท็กหรือชื่อก็ได้ อย่างไรก็ตาม ข้อมูลการแม็พที่เหมาะสมสำหรับคุณสมบัติที่มีชื่อตามที่ระบุโดยที่จัดเก็บการแม็พ&lt;/p&gt;</description></item><item><title>OFT - ไฟล์เทมเพลตอีเมล Microsoft Outlook</title><link>https://www.aspose.info/th/email/oft/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/oft/</guid><description>&lt;h2 id="ไฟล-oft-คออะไร"&gt;ไฟล์ OFT คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-oft-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ที่มีนามสกุล .oft เป็นไฟล์เทมเพลตที่สร้างขึ้นโดยใช้ Microsoft Outlook ชุดเค้าโครงที่จัดรูปแบบไว้ล่วงหน้าสำหรับเทมเพลตข้อความจะใช้สำหรับการส่งอีเมลพร้อมข้อมูลทั่วไปเพื่อประหยัดเวลา ไฟล์ดังกล่าวสามารถสร้างได้โดยสร้างอีเมลใหม่ เพิ่มข้อมูลที่จำเป็น จากนั้นใช้ดร็อปดาวน์บันทึกเป็นเทมเพลต Office (.oft) จาก Microsoft Outlook ผู้ใช้สามารถเปิดไฟล์ OFT ได้โดยการดับเบิลคลิกที่ไฟล์ และไฟล์นั้นจะเปิดขึ้นในแอปพลิเคชันที่เกี่ยวข้องกับระบบนั้นๆ&lt;/p&gt;&#10;&lt;h2 id="โครงสรางไฟล-oft"&gt;โครงสร้างไฟล์ OFT&lt;a class="anchor" href="#%e0%b9%82%e0%b8%84%e0%b8%a3%e0%b8%87%e0%b8%aa%e0%b8%a3%e0%b8%b2%e0%b8%87%e0%b9%84%e0%b8%9f%e0%b8%a5-oft" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;รูปแบบไฟล์ .OFT ใช้รูปแบบไฟล์ &lt;a href="https://www.aspose.info/th/email/msg/"&gt;MSG&lt;/a&gt; ที่ฐาน ข้อแตกต่างเพียงอย่างเดียวคือไฟล์ OFT มี CLSID_TemplateMessage ({0006F046-0000-0000-C000-000000000046}) เป็นคลาสพื้นที่เก็บข้อมูล (WriteClassStg) ในขณะที่ไฟล์ MSG ใช้ CLSID_MailMessage ({00020D0B-0000-0000-C000-000000000046})&lt;/p&gt;&#10;&lt;p&gt;รูปแบบ CFB_3 เป็นฐานของไฟล์ MSG กระบวนทัศน์นี้อิงตามแนวคิดของสตอเรจและสตรีม ซึ่งค่อนข้างใกล้เคียงกับไดเร็กทอรีและไฟล์ ดังนั้นความแตกต่างที่สำคัญในอดีตคือลำดับชั้นทั้งหมด ซึ่งบรรจุเป็นไฟล์ที่แตกต่างกัน เรียกว่าไฟล์ผสม อ็อบเจกต์ประกอบด้วยไฟล์ข้อความและประกอบด้วยคุณสมบัติเดียวหรือคอลเล็กชัน ความสามารถนี้ช่วยให้แอปพลิเคชันสามารถจัดเก็บข้อมูลที่มีโครงสร้างซับซ้อนไว้ในไฟล์เดียว รูปแบบนี้ยังระบุที่เก็บข้อมูลหลายที่ ซึ่งแต่ละที่เก็บข้อมูลจะแทนออบเจกต์ข้อความเป็นองค์ประกอบหลัก ที่เก็บข้อมูลเหล่านี้มีจำนวนสตรีมที่แสดงคุณสมบัติของส่วนประกอบนั้น นอกจากนี้ยังสามารถซ้อนที่เก็บข้อมูลได้อีกด้วย&lt;/p&gt;&#10;&lt;h3 id="คณสมบต-oft"&gt;คุณสมบัติ OFT&lt;a class="anchor" href="#%e0%b8%84%e0%b8%93%e0%b8%aa%e0%b8%a1%e0%b8%9a%e0%b8%95-oft" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;ที่ระดับบนสุดของไฟล์ .msg ที่เก็บข้อมูลประกอบด้วยสตรีมที่เก็บคุณสมบัติไว้ในนั้น สามารถแบ่งประเภทคุณสมบัติได้ดังนี้&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;คุณสมบัติความยาวคงที่&lt;/li&gt;&#10;&lt;li&gt;คุณสมบัติความยาวตัวแปร&lt;/li&gt;&#10;&lt;li&gt;คุณสมบัติหลายค่า&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;โดยไม่คำนึงถึงหมวดหมู่ พร็อพเพอร์ตี้อาจเป็นแท็กหรือชื่อก็ได้ อย่างไรก็ตาม ข้อมูลการแม็พที่เหมาะสมสำหรับคุณสมบัติที่มีชื่อตามที่ระบุโดยที่จัดเก็บการแม็พ&lt;/p&gt;</description></item><item><title>OLM - รูปแบบไฟล์ Outlook สำหรับ Mac</title><link>https://www.aspose.info/th/email/olm/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/olm/</guid><description>&lt;h2 id="ไฟล-olm-คออะไร"&gt;ไฟล์ OLM คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-olm-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ที่มีนามสกุล .olm คือไฟล์ Microsoft Outlook สำหรับระบบปฏิบัติการ Mac ไฟล์ OLM เก็บข้อความอีเมล วารสาร ข้อมูลปฏิทิน และข้อมูลแอปพลิเคชันประเภทอื่นๆ ไฟล์เหล่านี้คล้ายกับไฟล์ &lt;a href="https://www.aspose.info/th/email/pst/"&gt;PST&lt;/a&gt; ที่ใช้โดย Outlook บนระบบปฏิบัติการ Windows อย่างไรก็ตาม ไม่สามารถเปิดไฟล์ OLM ที่สร้างโดย Outlook for Mac ใน Outlook สำหรับ Windows รูปแบบไฟล์ OLM ถูกนำมาใช้กับ Outlook 2011 เพื่อจัดเก็บข้อมูลในเครื่องของ Outlook ไฟล์ OLM ไฟล์เดียวสามารถมีกล่องจดหมายได้หลายกล่อง โดยจัดระเบียบข้อมูลในรูปแบบของโฟลเดอร์และโฟลเดอร์ย่อย ไฟล์ OLM สามารถเปิด/โหลดใน Microsoft Outlook 365 และ Outlook for Mac&lt;/p&gt;&#10;&lt;h2 id="รปแบบไฟล-olm"&gt;รูปแบบไฟล์ OLM&lt;a class="anchor" href="#%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-olm" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;OLM เป็นไฟล์ไบนารีที่มีประเภท MIME ของ Application/octet-stream ข้อกำหนดทางเทคนิคของรูปแบบไฟล์ OLM ไม่พร้อมใช้งานอย่างเปิดเผยจาก Microsoft และไม่มีรายละเอียดรูปแบบสำหรับการอ้างอิงของนักพัฒนา อย่างไรก็ตาม มี API บางตัวที่สามารถอ่านรูปแบบไฟล์ OLM และเขียนลงในไฟล์ PST สำหรับใช้งานบนระบบปฏิบัติการ Microsoft Windows เช่น Aspose.Email&lt;/p&gt;</description></item><item><title>OST - รูปแบบไฟล์ที่เก็บข้อมูล Outlook</title><link>https://www.aspose.info/th/email/ost/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/ost/</guid><description>&lt;h2 id="ไฟล-ost-คออะไร"&gt;ไฟล์ OST คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-ost-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ OST หรือไฟล์จัดเก็บออฟไลน์แสดงข้อมูลกล่องจดหมายของผู้ใช้ในโหมดออฟไลน์บนเครื่องท้องถิ่นเมื่อลงทะเบียนกับ Exchange Server โดยใช้ Microsoft Outlook จะถูกสร้างขึ้นโดยอัตโนมัติเมื่อใช้ Microsoft Outlook ครั้งแรกเมื่อเชื่อมต่อกับเซิร์ฟเวอร์ เมื่อสร้างไฟล์แล้ว ข้อมูลจะถูกซิงโครไนซ์กับเซิร์ฟเวอร์อีเมลเพื่อให้สามารถใช้งานแบบออฟไลน์ได้ในกรณีที่ขาดการเชื่อมต่อจากเซิร์ฟเวอร์อีเมล ไฟล์ OST สามารถใช้รายการเมลบ็อกซ์ของผู้ใช้ เช่น อีเมล รายชื่อ ข้อมูลปฏิทิน บันทึกย่อ งาน และข้อมูลอื่นๆ ที่คล้ายคลึงกัน ผู้ใช้สามารถสร้างอีเมลและรายการข้อมูลอื่นๆ ในไฟล์ OST ได้แม้ว่าจะไม่มีการเชื่อมต่อกับเซิร์ฟเวอร์ แต่สิ่งเหล่านี้จะไม่ถูกซิงโครไนซ์กับเซิร์ฟเวอร์ เมื่อสร้างการเชื่อมต่อแล้ว ไฟล์ในเครื่องจะถูกซิงโครไนซ์กับเซิร์ฟเวอร์อีกครั้ง เพื่อให้ทั้งเซิร์ฟเวอร์และสำเนาในเครื่องอยู่ในระดับข้อมูลเดียวกัน&lt;/p&gt;&#10;&lt;h2 id="รปแบบไฟล-ost"&gt;รูปแบบไฟล์ OST&lt;a class="anchor" href="#%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-ost" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;รูปแบบไฟล์ OST (Offline Storage Table) และ &lt;a href="https://www.aspose.info/th/email/pst/"&gt;PST&lt;/a&gt; (Personal Storage Table) ประกอบด้วยรูปแบบไฟล์โฟลเดอร์ส่วนบุคคล (PFF) ที่สอดคล้องกับการจัดเก็บอีเมล ผู้ติดต่อ และการนัดหมายของผู้ใช้ ข้อมูลในไฟล์ PFF จัดเก็บในรูปแบบ little-endian โดยมีวันที่และเวลาทั้งหมดแสดงเป็น FILETIME ในรูปแบบ UTC [MS-PST] กำหนด PFF สองประเภท:&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;รูปแบบ ANSI 32 บิต&lt;/li&gt;&#10;&lt;li&gt;รูปแบบ Unicode 64 บิต&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;รูปแบบไฟล์ PST &lt;a href="https://learn.microsoft.com/en-us/openspecs/office_file_formats/ms-pst/141923d5-15ab-4ef1-a524-6dce75aae546"&gt;ข้อมูลจำเพาะ&lt;/a&gt; ที่มีให้จาก Microsoft ยังใช้กับรูปแบบไฟล์ OST ได้ฟรีและ การให้สิทธิ์ใช้งานสิทธิบัตรแบบเพิกถอนไม่ได้ผ่าน Open Specification Promise ประกอบด้วยองค์ประกอบที่แตกต่างดังต่อไปนี้:&lt;/p&gt;</description></item><item><title>PST - รูปแบบไฟล์ที่เก็บข้อมูลส่วนตัวของ Outlook</title><link>https://www.aspose.info/th/email/pst/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/pst/</guid><description>&lt;h2 id="ไฟล-pst-คออะไร"&gt;ไฟล์ PST คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-pst-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ที่มีนามสกุล .pst แสดงถึงไฟล์ที่เก็บข้อมูลส่วนตัวของ Outlook (เรียกอีกอย่างว่าตารางที่เก็บข้อมูลส่วนตัว) ที่เก็บข้อมูลต่างๆ ของผู้ใช้ ข้อมูลผู้ใช้ถูกจัดเก็บไว้ในโฟลเดอร์ประเภทต่างๆ ซึ่งรวมถึงอีเมล รายการปฏิทิน บันทึก รายชื่อ และรูปแบบไฟล์อื่นๆ ไฟล์ PST ใช้สำหรับเก็บข้อมูลอีเมลแบบออฟไลน์ซึ่งสามารถโหลดและดูในภายหลังในแอปพลิเคชันต่างๆ&lt;/p&gt;&#10;&lt;h2 id="ขอมลจำเพาะรปแบบไฟล-pst"&gt;ข้อมูลจำเพาะรูปแบบไฟล์ PST&lt;a class="anchor" href="#%e0%b8%82%e0%b8%ad%e0%b8%a1%e0%b8%a5%e0%b8%88%e0%b8%b3%e0%b9%80%e0%b8%9e%e0%b8%b2%e0%b8%b0%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-pst" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;รูปแบบไฟล์ PST &lt;a href="https://learn.microsoft.com/en-us/openspecs/office_file_formats/ms-pst/141923d5-15ab-4ef1-a524-6dce75aae546"&gt;ข้อมูลจำเพาะ&lt;/a&gt; มีให้ใช้งานจาก Microsoft เป็นสิทธิ์ใช้งานสิทธิบัตรฟรีและเพิกถอนไม่ได้ผ่าน Open Specifications Promise .&lt;/p&gt;&#10;&lt;h3 id="ประเภทของรปแบบ-pst"&gt;ประเภทของรูปแบบ PST&lt;a class="anchor" href="#%e0%b8%9b%e0%b8%a3%e0%b8%b0%e0%b9%80%e0%b8%a0%e0%b8%97%e0%b8%82%e0%b8%ad%e0%b8%87%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a-pst" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;รูปแบบไฟล์ PST แบ่งออกเป็นสองประเภทตามการเข้ารหัสของประเภทไฟล์ ไฟล์ PST ที่เข้ารหัส ANSI เป็นรูปแบบไฟล์ที่เก่ากว่าและรองรับโดย Outlook 2002 และเวอร์ชันก่อนหน้าเท่านั้น ไฟล์ดังกล่าวมีขนาดจำกัดสูงสุด 2 GB (2^^31^^ ไบต์) และไม่รองรับ Unicode ประเภทรูปแบบไฟล์ที่ทันสมัยกว่า ซึ่งใช้การเข้ารหัส Unicode ช่วยขจัดข้อจำกัดด้านขนาดไฟล์ และสามารถเข้าถึงขนาดข้อมูลสูงสุดที่ 50GB&lt;/p&gt;&#10;&lt;h3 id="การจดระเบยบเชงตรรกะของรปแบบไฟล-pst"&gt;การจัดระเบียบเชิงตรรกะของรูปแบบไฟล์ PST&lt;a class="anchor" href="#%e0%b8%81%e0%b8%b2%e0%b8%a3%e0%b8%88%e0%b8%94%e0%b8%a3%e0%b8%b0%e0%b9%80%e0%b8%9a%e0%b8%a2%e0%b8%9a%e0%b9%80%e0%b8%8a%e0%b8%87%e0%b8%95%e0%b8%a3%e0%b8%a3%e0%b8%81%e0%b8%b0%e0%b8%82%e0%b8%ad%e0%b8%87%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-pst" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;ที่ฐานของรูปแบบไฟล์ PST มี B-Tree ที่ช่วยจัดเรียงข้อมูลและอนุญาตให้ค้นหา เข้าถึงตามลำดับ แทรก ลบ ฯลฯ ในเวลาลอการิทึม โครงสร้างโดยรวมของไฟล์ PST แบ่งออกเป็นสามชั้น&lt;/p&gt;</description></item><item><title>ไฟล์ RPMSG - ไฟล์ข้อความอนุญาตจำกัดของ Outlook</title><link>https://www.aspose.info/th/email/rpmsg/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/rpmsg/</guid><description>&lt;h2 id="ไฟล-rpmsg-คออะไร"&gt;ไฟล์ RPMSG คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-rpmsg-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ RPMSG เป็นข้อความอีเมลเข้ารหัสที่สร้างขึ้นด้วยแอปพลิเคชันไคลเอ็นต์อีเมล Microsoft Outlook แอปพลิเคชันอีเมลและปฏิทินของ Microsoft ซึ่งจะถูกส่งเป็นไฟล์แนบแยกต่างหากไปยังข้อความอีเมลมาตรฐาน และผู้ใช้บางรายเท่านั้นที่สามารถเปิดได้ ซึ่งจะจำกัดการเข้าถึงไฟล์เหล่านี้ให้กับผู้ใช้รายอื่นที่ไม่ได้ถูกกำหนดให้รับข้อมูลในไฟล์เหล่านี้ โดยทั่วไปไฟล์เหล่านี้จะถูกส่งด้วยชื่อไฟล์ message.rpmsg และสามารถดาวน์โหลดได้จากอีเมลเช่นกัน แต่จะใช้งานไม่ได้ในกรณีนี้&lt;/p&gt;&#10;&lt;h2 id="รปแบบไฟล-rpmsg"&gt;รูปแบบไฟล์ RPMSG&lt;a class="anchor" href="#%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-rpmsg" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ RPMSG ถูกบันทึกลงดิสก์ในรูปแบบไฟล์ไบนารี อย่างไรก็ตาม ข้อมูลจำเพาะเกี่ยวกับรูปแบบไฟล์ไม่เปิดเผยต่อสาธารณะสำหรับการอ้างอิงของนักพัฒนาเนื่องจากการเข้ารหัส&lt;/p&gt;&#10;&lt;h2 id="อางอง"&gt;อ้างอิง&lt;a class="anchor" href="#%e0%b8%ad%e0%b8%b2%e0%b8%87%e0%b8%ad%e0%b8%87" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;&lt;a href="https://outlook.live.com/owa/"&gt;Microsoft Outlook&lt;/a&gt;&lt;/li&gt;&#10;&lt;/ul&gt;</description></item><item><title>ทส.</title><link>https://www.aspose.info/th/email/tnef/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/tnef/</guid><description>&lt;h2 id="ไฟล-tnef-คออะไร"&gt;ไฟล์ TNEF คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-tnef-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;Transport Neutral Encapsulation Format (TNEF) เป็นกรรมสิทธิ์ของ Microsoft สำหรับการห่อหุ้มไฟล์แนบอีเมลตาม Messaging Application Programming Interface (&lt;strong&gt;MAPI&lt;/strong&gt;) Microsoft Outlook และ Microsoft Exchange Server รองรับ TNEF ทั้งหมด ในขณะที่ภายหลังจะถอดรหัส TNEF เป็น MAPI และแสดงเมลที่จัดรูปแบบ ไฟล์แนบอีเมลที่มีการเข้ารหัส TNEF มีประเภท MIME คือ MS-TNEF และจัดเก็บเป็น winmail/win.dat ไฟล์แนบใน winmail .dat สรุปข้อมูลต่อไปนี้:&lt;/p&gt;&#10;&lt;table&gt;&#10;&#9;&lt;thead&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;ข้อความ&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;วัตถุ OLE&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;คุณลักษณะของ Outlook&lt;/th&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/thead&gt;&#10;&#9;&lt;tbody&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt; ไฟล์แนบข้อความต้นฉบับ&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt; เวอร์ชันดั้งเดิมที่จัดรูปแบบ&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt; แบบอักษร ขนาดข้อความ และสีข้อความ&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt; รูปภาพที่ฝัง&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt; เอกสาร Office แบบฝังตัว&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt; แบบฟอร์มที่กำหนดเอง&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt; ปุ่มลงคะแนน&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt; การเรียกประชุม&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/tbody&gt;&#10;&lt;/table&gt;&#10;&lt;p&gt;บริการอีเมลอื่นๆ ที่ไม่รองรับ TNEF จะแสดงข้อความธรรมดาสำหรับข้อความที่จัดรูปแบบ TNEF Outlook ฝังรูปแบบ Rich ของข้อความในไฟล์ TNEF (OLE) หรือคุณลักษณะเฉพาะของ Outlook (แบบฟอร์ม ปุ่มสำรวจ และคำขอการประชุม) ไม่อนุญาตให้เข้ารหัส TNEF ที่ชัดแจ้งภายในไคลเอนต์อีเมล Outlook อย่างไรก็ตาม การเลือกใช้รูปแบบ RTF เพื่อส่งอีเมลจะช่วยอำนวยความสะดวกในการเข้ารหัส TNEF โดยปริยาย&lt;/p&gt;</description></item><item><title>VCF - ไฟล์ติดต่อเสมือน</title><link>https://www.aspose.info/th/email/vcf/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/th/email/vcf/</guid><description>&lt;h2 id="ไฟล-vcf-คออะไร"&gt;ไฟล์ VCF คืออะไร??&lt;a class="anchor" href="#%e0%b9%84%e0%b8%9f%e0%b8%a5-vcf-%e0%b8%84%e0%b8%ad%e0%b8%ad%e0%b8%b0%e0%b9%84%e0%b8%a3" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;VCF (Virtual Card Format) หรือ vCard เป็นรูปแบบไฟล์ดิจิทัลสำหรับจัดเก็บข้อมูลผู้ติดต่อ รูปแบบนี้ใช้กันอย่างแพร่หลายสำหรับการแลกเปลี่ยนข้อมูลระหว่างแอปพลิเคชันแลกเปลี่ยนข้อมูลที่เป็นที่นิยม ระบบปฏิบัติการส่วนใหญ่ เช่น Windows และ MacOS มาพร้อมกับแอปพลิเคชันเริ่มต้นสำหรับสร้างและเปิดไฟล์เหล่านี้ ไฟล์ VCF ไฟล์เดียวสามารถมีข้อมูลผู้ติดต่อหนึ่งหรือหลายผู้ติดต่อ ไฟล์ VCF มักประกอบด้วยข้อมูล เช่น ชื่อผู้ติดต่อ ที่อยู่ หมายเลขโทรศัพท์ อีเมล วันเกิด รูปถ่ายและเสียง นอกเหนือไปจากฟิลด์อื่นๆ อีกจำนวนหนึ่ง ได้รับการสนับสนุนโดยไคลเอนต์อีเมลและบริการ ข้อมูลจะไม่สูญหายระหว่างการถ่ายโอนผู้ติดต่อโดยใช้รูปแบบ vCard ประเภทสื่อสำหรับรูปแบบไฟล์ VCF คือ text/vcard&lt;/p&gt;&#10;&lt;h2 id="รปแบบไฟล-vcf"&gt;รูปแบบไฟล์ VCF&lt;a class="anchor" href="#%e0%b8%a3%e0%b8%9b%e0%b9%81%e0%b8%9a%e0%b8%9a%e0%b9%84%e0%b8%9f%e0%b8%a5-vcf" aria-label="คัดลอกลิงก์ไปยังส่วนนี้"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;ไฟล์ VCF เป็นข้อความโดยธรรมชาติและมนุษย์สามารถอ่านได้ สามารถเปิดได้ในโปรแกรมแก้ไขข้อความ เช่น Notepad บน Microsoft Windows และ TextEdit บน MacOS อย่างไรก็ตาม หากมีรูปภาพในไฟล์ จะไม่แสดงในโปรแกรมแก้ไขข้อความ&lt;/p&gt;&#10;&lt;p&gt;&lt;a href="https://support.office.com/en-us/article/send-and-save-contacts-as-vcards-vcf-files-94a17a6f-105f-46c7-9308-33658c1c2690"&gt;Microsoft Outlook&lt;/a&gt; ให้การสนับสนุน การเปิดไฟล์ VCF และแปลงเป็นรูปแบบอื่นๆ เช่น รูปแบบ &lt;a href="https://www.aspose.info/th/email/msg/"&gt;MSG&lt;/a&gt; ยอดนิยม รูปแบบไฟล์ VCF ปรับปรุงตามเวลาตั้งแต่เวอร์ชัน 2.1 ถึง 4.0 โดยเพิ่มข้อมูลโดยละเอียดให้กับรูปแบบไฟล์ รูปแบบนี้ยังใช้เพื่อส่งออกรายชื่อติดต่อทางโทรศัพท์และนำเข้าในอุปกรณ์อื่นในภายหลัง&lt;/p&gt;</description></item></channel></rss>