<?xml version="1.0" encoding="utf-8" standalone="yes"?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom"><channel><title>了解可以打开和创建电子邮件文件的电子邮件文件格式和 API on aspose.info</title><link>https://www.aspose.info/zh/email/</link><description>Recent content in 了解可以打开和创建电子邮件文件的电子邮件文件格式和 API on aspose.info</description><generator>Hugo</generator><language>zh</language><lastBuildDate>Mon, 31 Jan 2022 00:00:00 +0000</lastBuildDate><atom:link href="https://www.aspose.info/zh/email/index.xml" rel="self" type="application/rss+xml"/><item><title>P7S 文件 - 数字签名的电子邮件</title><link>https://www.aspose.info/zh/email/p7s/</link><pubDate>Mon, 31 Jan 2022 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/p7s/</guid><description>&lt;h2 id="什么是一-p7s-文件"&gt;什么是一 .p7s 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-p7s-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;P7S 文件是通过数字签名电子邮件接收的数字签名。此文件作为电子邮件的附件存在，可验证该电子邮件是从真实来源发送的。这可确保发件人在其计算机上安装了电子邮件签名证书。当从用户的计算机发送此类签名的电子邮件时，会附上包含发件人姓名的 P7S 文件。支持签名电子邮件的电子邮件客户端可以看到发件人的信息。&lt;/p&gt;&#10;&lt;h2 id="p7s-文件格式---更多信息"&gt;P7S 文件格式 - 更多信息&lt;a class="anchor" href="#p7s-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f---%e6%9b%b4%e5%a4%9a%e4%bf%a1%e6%81%af" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;S/MIME（安全/多用途 Internet 邮件扩展）P7S 文件包含人类可读的纯文本格式的信息。 Microsoft Outlook、Apple Mail 和 Mozilla Thunderbird 等电子邮件客户端支持从 S/MIME 电子邮件中读取数字签名信息。签署电子邮件验证发件人的身份，并告诉接收者该消息是真实的。从电子邮件客户端（作为 &lt;a href="https://www.aspose.info/zh/email/eml/"&gt;EML&lt;/a&gt; 或 &lt;a href="https://www.aspose.info/zh/email/msg/"&gt;MSG&lt;/a&gt;）下载电子邮件时，会发现这些 P7S 文件附在这些电子邮件中。&lt;/p&gt;&#10;&lt;p&gt;P7S 文件包含以下信息：&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;电子邮件的来源&lt;/li&gt;&#10;&lt;li&gt;发送日期和时间，&lt;/li&gt;&#10;&lt;li&gt;传输过程中是否被修改&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;此信息是使用公钥加密标准#7 (PKCS7) 技术嵌入的，用于将加密签名以数字方式附加到电子邮件中。&lt;/p&gt;&#10;&lt;h2 id="参考-"&gt;参考 ＃＃&lt;a class="anchor" href="#%e5%8f%82%e8%80%83-" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;&lt;a href="https://learn.microsoft.com/en-us/windows-hardware/drivers/devtest/signtool"&gt;微软签名工具&lt;/a&gt;&lt;/li&gt;&#10;&lt;/ul&gt;</description></item><item><title>EDB 文件格式 - Exchange 邮件数据库文件</title><link>https://www.aspose.info/zh/email/edb/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/edb/</guid><description>&lt;h2 id="什么是一-edb-文件"&gt;什么是一 .edb 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-edb-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;具有 .edb 文件扩展名的文件是由 Microsoft Exchange Server 创建的邮箱数据库，用于存储与邮件相关的数据。 EDB，Exchange 数据库，存储进程中和非 SMTP 的消息。 EDB 也称为可扩展存储引擎 (ESE) 数据库文件，并使用 b-tree 结构存储文件。作为存储文件，EDB 文件可以转换为其他邮件存储文件格式，例如 &lt;a href="https://www.aspose.info/zh/email/pst/"&gt;PST&lt;/a&gt; 和 &lt;a href="https://www.aspose.info/zh/email/ost/"&gt;OST&lt;/a&gt;。&lt;/p&gt;&#10;&lt;h2 id="教育局文件格式"&gt;教育局文件格式&lt;a class="anchor" href="#%e6%95%99%e8%82%b2%e5%b1%80%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;没有可供参考的官方/开放 EDB 文件格式规范。对文件格式进行逆向工程已经取得了一些进展，导致部分规范解码。根据这些，EDB 文件包括：&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;File Header - 包含数据库文件头信息&lt;/li&gt;&#10;&lt;li&gt;Fixed Size Pages - 包含由表和索引组成的数据库&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;h3 id="数据库文件头"&gt;数据库文件头&lt;a class="anchor" href="#%e6%95%b0%e6%8d%ae%e5%ba%93%e6%96%87%e4%bb%b6%e5%a4%b4" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;数据库文件头位于第一个数据库页面中，并且至少为 668 字节。除了其他字段外，文件头还包含“文件格式版本&amp;quot;和“文件类型&amp;quot;。&lt;/p&gt;&#10;&lt;p&gt;＃＃＃＃ 文件类型&lt;/p&gt;&#10;&lt;table&gt;&#10;&#9;&lt;thead&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;类型&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;描述&lt;/th&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/thead&gt;&#10;&#9;&lt;tbody&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;数据库&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;流媒体&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/tbody&gt;&#10;&lt;/table&gt;&#10;&lt;p&gt;&lt;code&gt;注意：&lt;/code&gt; 这些类型的标识符是未知的。&lt;/p&gt;&#10;&lt;h4 id="文件格式版本"&gt;文件格式版本&lt;a class="anchor" href="#%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f%e7%89%88%e6%9c%ac" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h4&gt;&#10;&lt;p&gt;EDB 的原始格式始于 1997 年 4 月，此后不断发展以应对变化。&lt;/p&gt;&#10;&lt;table&gt;&#10;&#9;&lt;thead&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;修订日期&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;版本&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;修订&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;说明&lt;/th&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/thead&gt;&#10;&#9;&lt;tbody&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1997 年 4 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000000&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;原版操作系统Beta格式。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1997 年 5 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000001&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;在目录中添加用于条件索引和 OLD 的列。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1997 年 6 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000002&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;在 IDB 中添加 fLocalizedText 标志。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1997 年 10 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000003&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;将 SPLIT_BUFFER 添加到空间树根页面。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1998 年 1 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000002&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;恢复修订以使 ESE97 保持向前兼容。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000003&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;将新的标记列添加到目录（“CallbackData&amp;quot;和“CallbackDependencies&amp;quot;）。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1998 年 5 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000004&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;超长值 (SLV) 支持：signSLV、fSLVExists 在 dbheader 中。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1998 年 5 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000005&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;新的 SLV 空间树。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1998 年 10 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000006&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;SLV 空间图。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1998 年 12 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000007&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;4 字节 IDXSEG。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1999 年 1 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000008&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;新模板列格式。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1999 年 6 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000009&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;已排序的模板列。用于 Windows XP SP3&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x0000000b&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;包含带有 ECC 校验和的页眉，用于 Exchange&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x0000000c&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;用于 Windows Vista (SP0)&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000620&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000011&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;支持 2 KiB、16 KiB 和 32 KiB 页面。带有额外 ECC 校验和的扩展页眉。列压缩。空间提示。用于 Windows 7 (SP0)&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;1999 年 5 月&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000623&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;0x00000000&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;新空间经理。&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/tbody&gt;&#10;&lt;/table&gt;&#10;&lt;h3 id="数据库文件"&gt;数据库文件&lt;a class="anchor" href="#%e6%95%b0%e6%8d%ae%e5%ba%93%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;EDB 数据库文件包含数据库中所有表的模式。此外，它还包括所有数据库表的记录和表的索引。它的位置由以下标识符确定。&lt;/p&gt;</description></item><item><title>EML - 电子邮件消息</title><link>https://www.aspose.info/zh/email/eml/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/eml/</guid><description>&lt;h2 id="什么是一-eml-文件"&gt;什么是一 .eml 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-eml-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;EML 文件格式表示使用 Outlook 和其他相关应用程序保存的电子邮件。几乎所有的电子邮件客户端都支持这种文件格式，因为它符合 RFC-822 Internet 消息格式标准。 Microsoft Outlook 是打开 EML 邮件类型的默认软件。 EML 文件可用于保存到光盘以及使用通信协议发送给收件人。&lt;/p&gt;&#10;&lt;h2 id="eml-简史"&gt;EML 简史&lt;a class="anchor" href="#eml-%e7%ae%80%e5%8f%b2" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;EML 文件格式规范按照 &lt;a href="https://www.ietf.org/rfc/rfc0822.txt"&gt;RFC 822&lt;/a&gt; 标准格式提供。在 RFC-822 之前，RFC-733 管理网络消息交换的规则，直到 1982 年，前者是通过建立 ARPA 标准作为对横向的改进而创建的。同时，微软为开发自己的电子邮件客户端（即 Outlook Express）创建了自己的 COM 模块。当 Microsoft 偏离开放标准并创建 &lt;a href="https://www.aspose.info/zh/email/pst/"&gt;PST&lt;/a&gt; 文件格式，其中电子邮件以高度结构化的数据库格式保存时，RFC-822 走上了被确立为专有格式的道路。当从 Microsoft Outlook 转发电子邮件时，这会导致非 Microsoft 电子邮件客户端的用户出现问题。&lt;/p&gt;&#10;&lt;p&gt;2001 年，822 标准被增强为 2822 - Internet 消息格式，目前用于创建、读取和发送 MIME RFC-822 格式的 EML 消息。&lt;/p&gt;&#10;&lt;h2 id="eml-文件格式规范"&gt;EML 文件格式规范&lt;a class="anchor" href="#eml-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f%e8%a7%84%e8%8c%83" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;EML 文件由两个不同的部分组成：&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;Headers - 包含有关消息头的信息&lt;/li&gt;&#10;&lt;li&gt;消息正文 - 包含一系列信息，可以包括消息内容、嵌入的图像和附件&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;h3 id="标题信息"&gt;标题信息###&lt;a class="anchor" href="#%e6%a0%87%e9%a2%98%e4%bf%a1%e6%81%af" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;EML 文件由标头信息和可选的消息正文组成。 EML 中的每个标题行都有两个部分，由冒号“:&amp;ldquo;分隔。第一个称为标题名称，冒号后面的称为标题正文。例如，此类标头包括：&lt;/p&gt;</description></item><item><title>EMLX - Apple 邮件文件格式</title><link>https://www.aspose.info/zh/email/emlx/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/emlx/</guid><description>&lt;h2 id="什么是一-emlx-文件"&gt;什么是一 .EMLX 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-emlx-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;EMLX 文件格式由 Apple 实施和开发。 Apple Mail 应用程序使用 EMLX 文件格式导出电子邮件。还有其他应用程序可以打开 EMLX 文件并将其转换为其他文件格式。&lt;/p&gt;&#10;&lt;h2 id="emlx-文件格式简史"&gt;EMLX 文件格式简史&lt;a class="anchor" href="#emlx-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f%e7%ae%80%e5%8f%b2" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;Mac OS X 操作系统采用了现有的电子邮件程序 NeXTMail，它是由 NeXT 创建的，作为 NeXTSTEP 操作系统的一部分。 Apple 在收购 NeXT 后提升了其功能，并成为现在的 Apple Mail 电子邮件应用程序，用作默认邮件客户端。通过 Apple Mail 导出的电子邮件直接保存为 EMLX 文件。此外，当有人在 Mac OS 上双击打开这些文件时，它是 EMLX 文件的默认邮件客户端。&lt;/p&gt;&#10;&lt;h2 id="emlx-文件格式"&gt;EMLX 文件格式&lt;a class="anchor" href="#emlx-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;EMLx 文件是简单的基于文本的文件，可以在任何文本编辑器（如记事本）中打开。 EMLX 文件结构由三部分组成：&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;消息的字节数 - 消息本身的长度，以 ASCII 十进制形式写入，以 0x0a 结尾&lt;/li&gt;&#10;&lt;li&gt;消息本身&lt;/li&gt;&#10;&lt;li&gt;XML plist 形式的消息元数据&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;借助从 Apple Mail 提取为 EMLX 并在文本编辑器中打开的以下示例电子邮件，可以更好地解释这些。&lt;/p&gt;&#10;&lt;h3 id="emlx-示例"&gt;EMLX 示例&lt;a class="anchor" href="#emlx-%e7%a4%ba%e4%be%8b" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;pre tabindex="0"&gt;&lt;code&gt;875 &#10;X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on ******.*********.***&#10;X-Spam-Level:&#10;X-Spam-Status: No, score#-3.2 required#4.2 tests#BAYES_00,RP_MATCHES_RCVD,&#10; SPF_PASS,TVD_SPACE_RATIO autolearn#ham version#3.3.2&#10;Received: from [127.0.0.1](******.*********.*** [***.**.**.**])&#10; by ******.*********.*** (8.14.5/8.14.5) with ESMTP id r2TN8m4U099571&#10; for &amp;lt;****@*********.***&amp;gt;; Fri, 29 Mar 2013 19:08:48 -0400 (EDT)&#10; (envelope-from ****@*********.***)&#10;Subject: very simple&#10;From: Sender &amp;lt;****@*********.***&amp;gt;&#10;Content-Type: text/plain; charset#us-ascii&#10;Message-Id: &amp;lt;4E83618E-BB56-404F-8595-87352648ADC7@*********.***&amp;gt;&#10;Date: Fri, 29 Mar 2013 19:09:06 -0400&#10;To: Reciever &amp;lt;****@*********.***&amp;gt;&#10;Content-Transfer-Encoding: 7bit&#10;Mime-Version: 1.0 (Apple Message framework v1283)&#10;X-Mailer: Apple Mail (2.1283)&#10;&#10;message Foo&#10;--&#10;Sender&#10;http://www.la-grange.net/karl/&#10;&#10;&amp;lt;!DOCTYPE plist PUBLIC &amp;#34;-//Apple//DTD PLIST 1.0//EN&amp;#34; &amp;#34;http://www.apple.com/DTDs/PropertyList-1.0.dtd&amp;#34;&amp;gt;&#10;&amp;lt;plist version#&amp;#34;1.0&amp;#34;&amp;gt;&#10;&amp;lt;dict&amp;gt;&#10; &amp;lt;key&amp;gt;date-sent&amp;lt;/key&amp;gt;&#10; &amp;lt;real&amp;gt;1364598546&amp;lt;/real&amp;gt;&#10; &amp;lt;key&amp;gt;flags&amp;lt;/key&amp;gt;&#10; &amp;lt;integer&amp;gt;8590195713&amp;lt;/integer&amp;gt;&#10; &amp;lt;key&amp;gt;original-mailbox&amp;lt;/key&amp;gt;&#10; &amp;lt;string&amp;gt;imap://********@127.0.0.1:11143/mail/2013/03&amp;lt;/string&amp;gt;&#10; &amp;lt;key&amp;gt;remote-id&amp;lt;/key&amp;gt;&#10; &amp;lt;string&amp;gt;41147&amp;lt;/string&amp;gt;&#10; &amp;lt;key&amp;gt;subject&amp;lt;/key&amp;gt;&#10; &amp;lt;string&amp;gt;very simple&amp;lt;/string&amp;gt;&#10;&amp;lt;/dict&amp;gt;&#10;&amp;lt;/plist&amp;gt;&#10;&lt;/code&gt;&lt;/pre&gt;&lt;p&gt;在本例中，875 显示消息的总长度。消息元数据包含在&lt;!-- raw HTML omitted --&gt;标签和标志如下所述：&lt;/p&gt;</description></item><item><title>ICS - iCalendar 文件格式</title><link>https://www.aspose.info/zh/email/ics/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/ics/</guid><description>&lt;h2 id="什么是一-ics-文件"&gt;什么是一 .ICS 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-ics-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;Internet 日历和调度核心对象规范 (iCalendar) 是用于交换和部署日历事件和调度的 Internet 标准 (RFC 2445)。 iCalendar 格式是可互操作的，从而确保在具有不同电子邮件应用程序的用户之间交换日历信息。 iCalendar 将输入数据格式化为多用途 Internet 邮件扩展 (MIME)，并促进通过不同传输协议交换对象。这些传输协议可以是 SMTP、HTTP、点对点异步通信和基于物理媒体的网络传输。&lt;/p&gt;&#10;&lt;p&gt;iCalendar 允许用户通过电子邮件将事件、日期/时间相关任务和忙/闲信息分享给可以回复的其他用户。 iCalendar 文件存储使用后缀“.ics&amp;quot;、“.iCalendar&amp;quot;或“.ifb&amp;quot;，MIME 类型为“text/calendar&amp;quot;。 iCalendar 保持独立，没有任何传输协议依赖。 Web 服务器（使用 HTTP 协议）可以传输 iCalendar 信息，并且网页可以使用 iCalendar 以嵌入形式包含 iCalendar 数据。&lt;/p&gt;&#10;&lt;h2 id="ics-文件格式简史"&gt;ICS 文件格式简史&lt;a class="anchor" href="#ics-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f%e7%ae%80%e5%8f%b2" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;1998 年，互联网工程任务组 (IETF) 将 iCalendar 定义为标准 (RFC 2445)。该标准由 Frank Dawson（Lotus Notes Corporation）和 Derik Stenerson（Microsoft）记录。 2009 年，Bernard Desruisseaux (Oracle) 再次将该标准改进为 RFC 5545。这次添加了一些新特性，弃用了一些过时的特性。 2016 年，RFC 7986 发布并扩充到原始 iCalendar RFC。 RFC 7986 为主要 VCALENDAR 对象添加了新特性，并且还为会议系统引入了新的支持特性。&lt;/p&gt;</description></item><item><title>MBOX - 电子邮件邮箱文件</title><link>https://www.aspose.info/zh/email/mbox/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/mbox/</guid><description>&lt;h2 id="什么是一-mbox-文件"&gt;什么是一 .mbox 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-mbox-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;MBox 文件格式是一个通用术语，表示用于收集电子邮件消息的容器。消息连同它们的附件一起存储在容器内。来自整个文件夹的消息保存在单个数据库文件中，新消息附加到文件末尾。许多应用程序和 API 提供对 MBox 文件格式的支持，例如 Apple Mail 和 Mozilla Thunderbird。&lt;/p&gt;&#10;&lt;h2 id="mbox-文件格式"&gt;MBOX 文件格式##&lt;a class="anchor" href="#mbox-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;MBox 文件格式在很长一段时间内一直处于非标准化状态，直到 2005 年应用程序/mbox 被标准化为 &lt;a href="https://tools.ietf.org/rfc/rfc4155.txt"&gt;RFC 4155&lt;/a&gt; 消息，采用 RFC 2822 格式, 在 MBox 文件格式中一个接一个地串联起来。每条消息都以用于标识消息发送者的分隔线开头，并且还标识最终接收者（传输路径中的最后一跳系统或充当接收者的系统）接收消息的日期和时间。邮箱）。每条消息通常以空行结束。数据库的结尾通常通过缺少任何附加数据或存在显式文件结束标记来识别。&lt;/p&gt;&#10;&lt;h2 id="从-mbox-文件中读取消息"&gt;从 MBox 文件中读取消息##&lt;a class="anchor" href="#%e4%bb%8e-mbox-%e6%96%87%e4%bb%b6%e4%b8%ad%e8%af%bb%e5%8f%96%e6%b6%88%e6%81%af" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;阅读器扫描 mbox 文件以查找 From_ 行。任何 From_ 行都标志着消息的开始。读者不应试图利用每个 From_ 行（文件开头之后）都是空白行这一事实。一旦阅读器找到一条消息，它就会从 From_ 行中提取（可能已损坏的）信封发件人和投递日期。然后读取直到下一个 From_ 行或文件末尾，以先到者为准。它剥离最后的空白行并删除 &amp;gt;From_ 行和 &amp;raquo;From_ 行等的引用。结果是一条 RFC 822 消息。&lt;/p&gt;&#10;&lt;h2 id="编码注意事项"&gt;编码注意事项##&lt;a class="anchor" href="#%e7%bc%96%e7%a0%81%e6%b3%a8%e6%84%8f%e4%ba%8b%e9%a1%b9" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;当收到的电子邮件包含 Mbox 文件作为附件并保存在另一个 Mbox 文件中时，MBox 文件的内容可能会变得不可逆转。为了避免这种情况，无论何时通过消息传递协议传输此类对象，消息传递系统都必须使用非透明传输编码（例如 BASE64 或 Quoted-Printable）对 mbox 数据库进行编码。如果收到不合规的数据，实施者还应准备好在本地对 mbox 数据进行编码。&lt;/p&gt;</description></item><item><title>MSG - Microsoft Outlook 电子邮件格式</title><link>https://www.aspose.info/zh/email/msg/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/msg/</guid><description>&lt;h2 id="什么是一-msg-文件"&gt;什么是一 .msg 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-msg-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;MSG 是 &lt;a href="https://products.office.com/en-us/outlook/email-and-calendar-software-microsoft-outlook?rtc#1"&gt;Microsoft Outlook&lt;/a&gt; 和 Exchange 用于存储电子邮件的一种文件格式、联系人、约会或其他任务。此类消息可能包含一个或多个电子邮件字段，包括发件人、收件人、主题、日期和消息正文，或联系信息、约会详情以及一个或多个任务规范。构成 Message 对象的属性，包括也是 MSG 文件的一部分。 MSG 文件具有作为纯 ASCII 文本的标题、主要消息正文和超链接。 MSG 文件也适用于需要 Microsoft 消息应用程序编程接口 (MAPI) 的程序。&lt;/p&gt;&#10;&lt;h2 id="味精文件结构"&gt;味精文件结构&lt;a class="anchor" href="#%e5%91%b3%e7%b2%be%e6%96%87%e4%bb%b6%e7%bb%93%e6%9e%84" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;CFB_3 格式是 MSG 文件的基础。该范例基于存储和流概念，非常接近目录和文件。因此，前者的一个主要区别是整个层次结构，打包成一个不同的文件，称为复合文件。对象构成消息文件并由单个属性或其集合组成。这种能力有助于应用程序将复杂的结构化数据存储在单个文件中。这种格式还指定了多个存储，每个存储都将消息对象表示为一个主要组件。这些存储包含许多表示该组件属性的流。也可以嵌套存储。&lt;/p&gt;&#10;&lt;h2 id="马比地产"&gt;马比地产&lt;a class="anchor" href="#%e9%a9%ac%e6%af%94%e5%9c%b0%e4%ba%a7" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;在 .msg 文件的顶层，存储包含在其中存储属性的流。属性可以分类如下：&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;固定长度属性&lt;/li&gt;&#10;&lt;li&gt;可变长度属性&lt;/li&gt;&#10;&lt;li&gt;多值属性&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;无论类别如何，属性要么是标记的，要么是命名的。但是，命名属性需要合适的映射信息，由它们的映射存储指定。&lt;/p&gt;&#10;&lt;h2 id="存储"&gt;存储&lt;a class="anchor" href="#%e5%ad%98%e5%82%a8" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;存储构成 Message 对象的关键组件。 MSG 文件格式规定了以下存储：&lt;/p&gt;&#10;&lt;h2 id="顶层结构"&gt;顶层结构&lt;a class="anchor" href="#%e9%a1%b6%e5%b1%82%e7%bb%93%e6%9e%84" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;Message 对象代表了整个 MSG 文件格式的顶层。根据类型、属性、收件人和附件对象的数量，消息对象可以在其相应的 .MSG 文件中具有不同的流存储。&lt;/p&gt;&#10;&lt;h3 id="与其他结构的关系"&gt;与其他结构的关系&lt;a class="anchor" href="#%e4%b8%8e%e5%85%b6%e4%bb%96%e7%bb%93%e6%9e%84%e7%9a%84%e5%85%b3%e7%b3%bb" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;Msg 文件格式与其他结构有以下关系：&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;.msg 的基础是复合文件二进制文件格式。&lt;/li&gt;&#10;&lt;li&gt;此格式使用消息和附件对象协议使用的属性。&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;h2 id="避免-msg-格式的场景"&gt;避免 MSG 格式的场景&lt;a class="anchor" href="#%e9%81%bf%e5%85%8d-msg-%e6%a0%bc%e5%bc%8f%e7%9a%84%e5%9c%ba%e6%99%af" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;消息对象可以在使用 .msg 文件系统的客户端或消息存储之间共享。在少数情况下，不适合以 .msg 文件格式存储 Message 对象。例如：&lt;/p&gt;</description></item><item><title>OFT - Microsoft Outlook 电子邮件模板文件</title><link>https://www.aspose.info/zh/email/oft/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/oft/</guid><description>&lt;h2 id="什么是一-oft-文件"&gt;什么是一 .oft 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-oft-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;带有 .oft 扩展名的文件是使用 Microsoft Outlook 创建的模板文件。消息模板的预格式化布局集随后用于发送包含通用信息的电子邮件以节省时间。可以通过创建新电子邮件、添加必要信息然后使用 Microsoft Outlook 中的另存为 Office 模板 (.oft) 下拉菜单来生成此类文件。用户可以通过双击打开 OFT 文件，它将在该特定系统上的相关应用程序中打开。&lt;/p&gt;&#10;&lt;h2 id="oft-文件结构"&gt;OFT 文件结构##&lt;a class="anchor" href="#oft-%e6%96%87%e4%bb%b6%e7%bb%93%e6%9e%84" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;.OFT 文件格式在其基础上使用 &lt;a href="https://www.aspose.info/zh/email/msg/"&gt;MSG&lt;/a&gt; 文件格式。唯一不同的是，OFT 文件使用 CLSID_TemplateMessage ({0006F046-0000-0000-C000-000000000046}) 作为存储类 (WriteClassStg)，而 MSG 文件使用 CLSID_MailMessage ({00020D0B-0000-0000-C000-000000000046})。&lt;/p&gt;&#10;&lt;p&gt;CFB_3 格式是 MSG 文件的基础。该范例基于存储和流概念，非常接近目录和文件。因此，前者的一个主要区别是整个层次结构，打包成一个不同的文件，称为复合文件。对象构成消息文件并由单个属性或其集合组成。这种能力有助于应用程序将复杂的结构化数据存储在单个文件中。这种格式还指定了多个存储，每个存储都将消息对象表示为一个主要组件。这些存储包含许多表示该组件属性的流。也可以嵌套存储。&lt;/p&gt;&#10;&lt;h3 id="oft-属性"&gt;OFT 属性&lt;a class="anchor" href="#oft-%e5%b1%9e%e6%80%a7" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;在 .msg 文件的顶层，存储包含在其中存储属性的流。属性可以分类如下：&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;固定长度属性&lt;/li&gt;&#10;&lt;li&gt;可变长度属性&lt;/li&gt;&#10;&lt;li&gt;多值属性&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;无论类别如何，属性要么是标记的，要么是命名的。但是，命名属性需要合适的映射信息，由它们的映射存储指定。&lt;/p&gt;&#10;&lt;h3 id="oft-存储"&gt;OFT 存储&lt;a class="anchor" href="#oft-%e5%ad%98%e5%82%a8" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;存储构成 Message 对象的关键组件。 MSG 文件格式规定了以下存储：&lt;/p&gt;&#10;&lt;h3 id="顶层结构"&gt;顶层结构&lt;a class="anchor" href="#%e9%a1%b6%e5%b1%82%e7%bb%93%e6%9e%84" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;Message 对象表示整个 Msg 文件格式的顶层。根据类型、属性、收件人和附件对象的数量，消息对象可以在其相应的 .MSG 文件中具有不同的流存储。&lt;/p&gt;&#10;&lt;h4 id="与其他结构的关系"&gt;与其他结构的关系&lt;a class="anchor" href="#%e4%b8%8e%e5%85%b6%e4%bb%96%e7%bb%93%e6%9e%84%e7%9a%84%e5%85%b3%e7%b3%bb" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h4&gt;&#10;&lt;p&gt;MSG/OFT 文件格式与其他结构有以下关系：&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;.msg 的基础是复合文件二进制文件格式。&lt;/li&gt;&#10;&lt;li&gt;此格式使用消息和附件对象协议使用的属性。&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;h2 id="参考"&gt;参考&lt;a class="anchor" href="#%e5%8f%82%e8%80%83" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;&lt;a href="https://msdn.microsoft.com/en-us/library/cc463912%28v#exchg.80%29.aspx"&gt;[MS-OXMSG]: Outlook MSG 文件格式&lt;/a&gt;&lt;/li&gt;&#10;&lt;/ul&gt;</description></item><item><title>OLM - Outlook for Mac 文件格式</title><link>https://www.aspose.info/zh/email/olm/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/olm/</guid><description>&lt;h2 id="什么是一-olm-文件"&gt;什么是一 .olm 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-olm-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;带有 .olm 扩展名的文件是适用于 Mac 操作系统的 Microsoft Outlook 文件。 OLM 文件存储电子邮件、日志、日历数据和其他类型的应用程序数据。这些类似于 Windows 操作系统上 Outlook 使用的 &lt;a href="https://www.aspose.info/zh/email/pst/"&gt;PST&lt;/a&gt; 文件。但是，由 Outlook for Mac 创建的 OLM 文件无法在 Outlook for Windows 中打开。 OLM 文件格式是在 Outlook 2011 中引入的，用于存储 Outlook 的本地数据。单个 OLM 文件可以包含多个邮箱，以文件夹和子文件夹的形式组织数据。 OLM 文件可以在 Microsoft Outlook 365 和 Outlook for Mac 中打开/加载。&lt;/p&gt;&#10;&lt;h2 id="olm-文件格式"&gt;OLM 文件格式&lt;a class="anchor" href="#olm-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;OLM 是具有 Application/octet-stream MIME 类型的二进制文件。 Microsoft 未公开提供 OLM 文件格式的技术规范，也没有可供开发人员参考的格式详细信息。但是，有一些 API 可以读取 OLM 文件格式并将其写入 PST 文件，以便在 Microsoft Windows 操作系统（例如 Aspose.Email）上使用。&lt;/p&gt;</description></item><item><title>OST - Outlook 存储文件格式</title><link>https://www.aspose.info/zh/email/ost/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/ost/</guid><description>&lt;h2 id="什么是一-ost-文件"&gt;什么是一 .ost 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-ost-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;OST 或脱机存储文件代表用户在使用 Microsoft Outlook 向 Exchange Server 注册时在本地计算机上处于脱机模式的邮箱数据。它是在与服务器连接后首次使用 Microsoft Outlook 时自动创建的。创建文件后，数据将与电子邮件服务器同步，以便在与电子邮件服务器断开连接的情况下也可以脱机使用。 OST 文件可以用户邮箱项目，如电子邮件、联系人、日历信息、便笺、任务和其他类似数据。即使没有连接到服务器，用户也可以在 OST 文件中创建电子邮件和其他数据项，但这些不会与服务器同步。建立连接后，本地文件再次与服务器同步，使服务器和本地副本处于同一信息级别。&lt;/p&gt;&#10;&lt;h2 id="ost-文件格式"&gt;OST 文件格式&lt;a class="anchor" href="#ost-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;OST（离线存储表）和 &lt;a href="https://www.aspose.info/zh/email/pst/"&gt;PST&lt;/a&gt;（个人存储表）文件格式由对应于存储用户的电子邮件、联系人和约会的个人文件夹文件 (PFF) 格式组成。 PFF 文件中的数据以 little-endian 格式存储，所有日期和时间均以 UTC 格式的 FILETIME 表示。 [MS-PST] 定义了两种类型的 PFF：&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;32 位 ANSI 格式&lt;/li&gt;&#10;&lt;li&gt;64 位 Unicode 格式&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;p&gt;PST 文件格式 &lt;a href="https://learn.microsoft.com/en-us/openspecs/office_file_formats/ms-pst/141923d5-15ab-4ef1-a524-6dce75aae546"&gt;规范&lt;/a&gt; 可从 Microsoft 获得，也适用于免费和免费的 OST 文件格式通过 Open Specification Promise 获得不可撤销的专利许可。它由以下可区分的元素组成：&lt;/p&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;文件头&lt;/li&gt;&#10;&lt;li&gt;文件头数据&lt;/li&gt;&#10;&lt;li&gt;索引分支节点&lt;/li&gt;&#10;&lt;li&gt;索引叶节点&#10;*（文件）偏移索引&#10;*（项目）描述符索引&lt;/li&gt;&#10;&lt;li&gt;本地描述符&lt;/li&gt;&#10;&lt;li&gt;项目表类型&lt;/li&gt;&#10;&lt;/ul&gt;&#10;&lt;h3 id="标头信息"&gt;标头信息&lt;a class="anchor" href="#%e6%a0%87%e5%a4%b4%e4%bf%a1%e6%81%af" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;OST 文件的 HEADER 结构位于文件的最开始处 0 偏移处。它包含有关 OST 文件的元数据信息和用于访问上述 NDB 层数据结构的 ROOT 信息。 OST 文件格式的 Unicode 和 ANSI 版本的 HEADER 结构不同。&lt;/p&gt;</description></item><item><title>PST - Outlook 个人信息存储文件格式</title><link>https://www.aspose.info/zh/email/pst/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/pst/</guid><description>&lt;h2 id="什么是一-pst-文件"&gt;什么是一 .pst 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-pst-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;带有 .pst 扩展名的文件表示存储各种用户信息的 Outlook 个人存储文件（也称为个人存储表）。用户信息存储在不同类型的文件夹中，包括电子邮件、日历项目、便笺、联系人和其他几种文件格式。 PST 文件用于离线归档电子邮件数据，以后可以在各种应用程序中加载和查看这些数据。&lt;/p&gt;&#10;&lt;h2 id="pst-文件格式规范"&gt;PST 文件格式规范&lt;a class="anchor" href="#pst-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f%e8%a7%84%e8%8c%83" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;PST 文件格式 &lt;a href="https://learn.microsoft.com/en-us/openspecs/office_file_formats/ms-pst/141923d5-15ab-4ef1-a524-6dce75aae546"&gt;规范&lt;/a&gt; 可通过开放规范承诺从 Microsoft 作为免费且不可撤销的免费专利许可获得.&lt;/p&gt;&#10;&lt;h3 id="pst-格式的类型"&gt;PST 格式的类型&lt;a class="anchor" href="#pst-%e6%a0%bc%e5%bc%8f%e7%9a%84%e7%b1%bb%e5%9e%8b" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;PST 文件格式根据文件类型的编码分为两种类型。 ANSI 编码的 PST 文件是较旧的文件格式，仅受 Outlook 2002 和更早版本支持。此类文件的最大大小限制为 2 GB（2^^31^^ 字节）并且不支持 Unicode。一种更现代的文件格式类型，基于 Unicode 编码，消除了文件大小限制，最大数据大小可达 50GB。&lt;/p&gt;&#10;&lt;h3 id="pst-文件格式的逻辑组织"&gt;PST 文件格式的逻辑组织&lt;a class="anchor" href="#pst-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f%e7%9a%84%e9%80%bb%e8%be%91%e7%bb%84%e7%bb%87" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;PST 文件格式的基础是 B-Tree，它保持数据排序并允许在对数时间内进行搜索、顺序访问、插入、删除等。 PST 文件的整体结构分为三层。&lt;/p&gt;&#10;&lt;p&gt;&lt;img src="https://www.aspose.info/zh/email/PST-1.png" alt="Logical layers of a PST file" title="Logical layers of a PST file"&gt;&lt;/p&gt;&#10;&lt;p&gt;&lt;code&gt;Node Database (NDB) Layer&lt;/code&gt; - 节点数据库层位于 PST 文件的较低级别，包括节点数据库。这些节点实际上代表 PST 文件格式的较低级别的存储设施。从存储的角度来看，NDB 层由标头、文件分配信息、块和 BTree（Node BTree 和 Block BTree）组成。 NDB 层的节点和块通过数据 BID 链接，数据 BID 是节点引用的四个属性之一，即 NID（节点 ID）、父 NID、数据 BID（块 BID）和子节点 BID。&lt;/p&gt;</description></item><item><title>RPMSG 文件 - Outlook 受限权限消息文件</title><link>https://www.aspose.info/zh/email/rpmsg/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/rpmsg/</guid><description>&lt;h2 id="什么是一-rpmsg-文件"&gt;什么是一 RPMSG 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-rpmsg-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;RPMSG 文件是使用电子邮件客户端应用程序 Microsoft Outlook、Microsoft 的电子邮件和日历应用程序创建的加密电子邮件消息。它作为标准电子邮件的单独附件发送，并且只能由某些用户打开。这会将这些文件的访问权限限制为其他用户，这些用户注定不会接收这些文件中的信息。通常这些文件以文件名 message.rpmsg 发送，也可以从电子邮件中下载，但在这种情况下不起作用。&lt;/p&gt;&#10;&lt;h2 id="rpmsg-文件格式"&gt;RPMSG 文件格式&lt;a class="anchor" href="#rpmsg-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;RPMSG 文件以二进制文件格式保存到光盘中。但是，由于加密，其文件格式规范不公开供开发人员参考。&lt;/p&gt;&#10;&lt;h2 id="参考"&gt;参考&lt;a class="anchor" href="#%e5%8f%82%e8%80%83" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;ul&gt;&#10;&lt;li&gt;&lt;a href="https://outlook.live.com/owa/"&gt;微软 Outlook&lt;/a&gt;&lt;/li&gt;&#10;&lt;/ul&gt;</description></item><item><title>TNEF</title><link>https://www.aspose.info/zh/email/tnef/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/tnef/</guid><description>&lt;h2 id="什么是一-tnef-文件"&gt;什么是一 .TNEF 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-tnef-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;传输中性封装格式 (TNEF) 是 Microsoft 专有的，用于封装基于消息应用程序编程接口 (&lt;strong&gt;MAPI&lt;/strong&gt;) 的电子邮件附件。 Microsoft Outlook 和 Microsoft Exchange Server 完全支持 TNEF，稍后将 TNEF 解码为 MAPI 并显示格式化的邮件。带有 TNEF 编码的电子邮件附件的 MIME 类型为 MS-TNEF，并存储为 winmail/win.dat。 winmail .dat 中的附件封装了以下信息：&lt;/p&gt;&#10;&lt;table&gt;&#10;&#9;&lt;thead&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;消息&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;OLE 对象&lt;/th&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;th&gt;Outlook 功能&lt;/th&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/thead&gt;&#10;&#9;&lt;tbody&gt;&#10;&#9;&#9;&#9;&lt;tr&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;原始邮件附件&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;原始格式化版本&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;字体、文本大小和文本颜色&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;嵌入图片&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;嵌入式 Office 文档&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&#9;&#9;&lt;td&gt;&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;自定义表格&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;投票按钮&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;会议要求&lt;!-- raw HTML omitted --&gt;&lt;!-- raw HTML omitted --&gt;&lt;/td&gt;&#10;&#9;&#9;&#9;&lt;/tr&gt;&#10;&#9;&lt;/tbody&gt;&#10;&lt;/table&gt;&#10;&lt;p&gt;其他不支持 TNEF 的电子邮件服务会为 TNEF 格式的邮件提供纯文本。 Outlook 在 TNEF 文件 (OLE) 或特定 Outlook 功能（表单、轮询按钮和会议请求）中嵌入了丰富格式的邮件。在 Outlook 电子邮件客户端中批准显式 TNEF 编码是不可能的，但是，选择用于发送电子邮件的 RTF 格式隐式地促进了 TNEF 编码。&lt;/p&gt;</description></item><item><title>VCF - 虚拟联系人文件</title><link>https://www.aspose.info/zh/email/vcf/</link><pubDate>Fri, 11 Oct 2019 00:00:00 +0000</pubDate><guid>https://www.aspose.info/zh/email/vcf/</guid><description>&lt;h2 id="什么是一-vcf-文件"&gt;什么是一 .vcf 文件？&lt;a class="anchor" href="#%e4%bb%80%e4%b9%88%e6%98%af%e4%b8%80-vcf-%e6%96%87%e4%bb%b6" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;VCF（虚拟卡格式）或 vCard 是一种用于存储联系人信息的数字文件格式。该格式广泛用于流行的信息交换应用程序之间的数据交换。大多数操作系统（如 Windows 和 MacOS）都带有用于创建和打开这些文件的默认应用程序。单个 VCF 文件可以包含一个或多个联系人的联系信息。 VCF 文件通常包含联系人姓名、地址、电话号码、电子邮件、生日、照片和音频等信息，以及许多其他字段。在电子邮件客户端和服务的支持下，通过使用 vCard 格式传输联系人时不会丢失数据。 VCF 文件格式的媒体类型是 text/vcard。&lt;/p&gt;&#10;&lt;h2 id="vcf-文件格式"&gt;VCF 文件格式&lt;a class="anchor" href="#vcf-%e6%96%87%e4%bb%b6%e6%a0%bc%e5%bc%8f" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h2&gt;&#10;&lt;p&gt;VCF 文件本质上是文本的，并且是人类可读的。这些可以在文本编辑器中打开，例如 Microsoft Windows 上的记事本和 MacOS 上的 TextEdit。但是，如果文件中有图像，它将不会显示在文本编辑器中。&lt;/p&gt;&#10;&lt;p&gt;&lt;a href="https://support.office.com/en-us/article/send-and-save-contacts-as-vcards-vcf-files-94a17a6f-105f-46c7-9308-33658c1c2690"&gt;Microsoft Outlook&lt;/a&gt; 提供支持打开 VCF 文件以及转换为许多其他格式，例如流行的 &lt;a href="https://www.aspose.info/zh/email/msg/"&gt;MSG&lt;/a&gt; 格式。 VCF 文件格式随着从 2.1 版到 4.0 版的改进，为文件格式添加了详细信息。该格式还用于导出电话联系人，然后导入另一台设备。&lt;/p&gt;&#10;&lt;figure&gt;&lt;img src="../VCF.png"&#10;&#9;&#9;&#9;alt="VCF 文件格式"&gt;&#10;&lt;/figure&gt;&#10;&#10;&lt;h3 id="vcf-21-示例"&gt;VCF 2.1 示例&lt;a class="anchor" href="#vcf-21-%e7%a4%ba%e4%be%8b" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;以下是 2.1 版的示例。&lt;/p&gt;&#10;&lt;pre tabindex="0"&gt;&lt;code&gt;BEGIN:VCARD&#10;VERSION:2.1&#10;N:Gump;Forrest;;Mr.&#10;FN:Forrest Gump&#10;ORG:Bubba Gump Shrimp Co.&#10;TITLE:Shrimp Man&#10;PHOTO;GIF:http://www.example.com/dir_photos/my_photo.gif&#10;TEL;WORK;VOICE:(111) 555-1212&#10;TEL;HOME;VOICE:(404) 555-1212&#10;ADR;WORK;PREF:;;100 Waters Edge;Baytown;LA;30314;United States of America&#10;LABEL;WORK;PREF;ENCODING#QUOTED-PRINTABLE;CHARSET#UTF-8:100 Waters Edge#0D#&#10; #0ABaytown\, LA 30314#0D#0AUnited States of America&#10;ADR;HOME:;;42 Plantation St.;Baytown;LA;30314;United States of America&#10;LABEL;HOME;ENCODING#QUOTED-PRINTABLE;CHARSET#UTF-8:42 Plantation St.#0D#0A#&#10; Baytown, LA 30314#0D#0AUnited States of America&#10;EMAIL:forrestgump@example.com&#10;REV:20080424T195243Z&#10;END:VCARD&#10;&lt;/code&gt;&lt;/pre&gt;&lt;h3 id="vcf-30-示例"&gt;VCF 3.0 示例&lt;a class="anchor" href="#vcf-30-%e7%a4%ba%e4%be%8b" aria-label="复制此部分的链接"&gt;&lt;/a&gt;&lt;/h3&gt;&#10;&lt;p&gt;以下是 3.0 版本的示例。&lt;/p&gt;</description></item></channel></rss>